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You cannot install Windows Server 2003 successfully after you use Windows Vista or Windows PE 2.0 to create partitions on a hard disk


View products that this article applies to.

Symptoms

You use Windows Vista or Windows Preinstallation Environment (Windows PE) 2.0 to create partitions on a hard disk. After you do this, you try to install Microsoft Windows Server 2003 on the hard disk without using Windows Server 2003 to repartition the disk. In this case, you cannot install Windows Server 2003 successfully.

Windows Server 2003 Setup will successfully complete the text-mode part of Setup. However, after the text-mode part of Setup is complete, the computer cannot be restarted successfully to enter the GUI-mode part of Setup. Additionally, the computer may stop responding. You may receive an error message that resembles one of the following:
A disk read error occurred
Unable to load operating system
Error loading operating system
When you deploy a Windows Server 2003 sysprep image to a system, the system may continuously restart after you start the system for the first time. If you press F8 and then disable the "automatic restart" option, you may receive the following Stop error:
Stop: 0x000000ED (0X81F85678, 0xC000014F,0x00000000,0x00000000)
Unmountable_boot_volume
Additionally, if you view the disk in Windows PE 2.0, the disk may appear as "raw."

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Cause

This problem occurs because Windows Vista and Windows PE 2.0 create disk partitions differently than Windows Server 2003. This problem occurs only on computers that use certain BIOS firmware.

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Workaround

Note The workarounds that are listed here should be used only if integrating the hotfix into your Windows Server 2003 installation source is not viable. See the "Resolution" section for more information. If you integrate the hotfix into the installation source as described in the "Resolution" section, you do not have to use these workarounds.

To work around this problem, use one of the following methods.

Method 1: Disable the "automatic disk translation" feature

Before you partition the hard disk, you can disable the "automatic disk translation" feature in the BIOS configuration. For example, you can change the disk type from Auto to Large.

Method 2: Modify the registry to use the Windows Server 2003 disk partition procedure

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows


Before you partition the hard disk in Windows Vista or in Windows PE 2.0, modify the registry so that the partitions are created by using the Windows Server 2003 procedure. To do this, follow these steps:
  1. Click Start, click Run, type Regedit, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CURRENTCONTROLSET\SERVICES\VDS\ALIGNMENT
  3. On the Edit menu, point to New, and then click DWORD value.
  4. Type LessThan4GB as the new entry name.
  5. Right-click LessThan4GB, and then click Modify.
  6. In the Edit DWORD Value dialog box, click Decimal.
  7. In the Value data box, type 0, and then click OK.
  8. Repeat steps 3 through 7 to add the following registry entries:
    • Between4_8GB
    • Between8_32GB
    • GreaterThan32GB
    Each registry entry must have a value of 0.
  9. Exit Registry Editor.
When you use the Windows Vista or Windows PE 2.0 partition procedure to create a partition, the partition border is constructed based on the registry setting on the system. On the other hand, when you use the Windows Server 2003 partition procedure to create a partition, the partition border is aligned according to the cylinder boundary.

When you create a partition, the free space that is followed by the first partition is created at the beginning of the disk. The size of the free space is determined based on how the partition border is constructed. Therefore, the size may vary, depending on how the partition is created.

When you create a partition by using the Windows Server 2003 procedure, this free space is equal to one cylinder. However, when you use the Windows Vista or Windows PE 2.0 procedure, the free space varies, depending on the registry setting.

Method 3

If you are using Microsoft Deployment Toolkit 2008 to deploy Windows XP, follow these steps to work around this issue:
  1. In the properties of the Task Sequence, click the Task Sequence tab.
  2. Click Preinstall, and then click New Computer Only.
  3. Click Set Diskpart BIOS Compatability mode.
  4. Click the Options tab.
  5. Click to clear the Disable this step check box.

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Resolution

To resolve this problem, you must integrate the hotfix into the source files of the Windows Server 2003 installation before you install Windows Server 2003. For more information about how to integrate this hotfix into the Windows installation source files, click the following article number to view the article in the Microsoft Knowledge Base:
828930 How to integrate software updates into your Windows installation source files

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

This hotfix requires that Microsoft Windows Server 2003 Service Pack 1 (SP1) be installed on the computer.

889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with SP1, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Ntoskrnl.exe5.2.3790.28662,420,73622-Jan-200711:18x86
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Ntoskrnl.exe5.2.3790.28664,484,09622-Jan-200702:36x64
Windows Server 2003 with Service Pack 2 (SP2), x86-based versions
File nameFile versionFile sizeDateTimePlatform
Ntoskrnl.exe5.2.3790.40082,430,46422-Jan-200715:38x86
Windows Server 2003 with SP2, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Ntoskrnl.exe5.2.3790.40084,497,40822-Jan-200702:41x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: KB931761, kbhotfixserver, kbqfe, kbexpertiseinter, kbfix, kbautohotfix

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Article Info
Article ID : 931761
Revision : 7
Created on : 8/14/2009
Published on : 8/14/2009
Exists online : False
Views : 202