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Error message when you use the Reg.exe tool to query a registry subkey on a computer that is running Windows Server 2003 with SP1 or Windows Server 2003 with SP2: "ERROR: More data is available"


View products that this article applies to.

Symptoms

On a computer that is running Microsoft Windows Server 2003 with Service Pack 1 (SP1) or Windows Server 2003 with Service Pack 2 (SP2), you use the Reg.exe tool to query a registry subkey. However, you receive the following error message:
ERROR: More data is available.
This issue occurs if the registry subkey contains REG_MULTI_STRING registry entries that do not contain any value data. These empty registry entries are not displayed in the query result.

Note In the original release versions of Windows Server 2003, the Reg.exe tool returns a 0x0 value for an empty REG_MULTI_STRING registry entry.

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Cause

This problem occurs because the Reg.exe tool does not correctly handle NULL value data for REG_MULTI_STRING registry entries.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2 installed on the computer. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Reg.exe5.2.3790.286980,38425-Jan-200710:37x86SP1SP1QFE
Reg.exe5.2.3790.401180,38425-Jan-200719:34x86SP2SP2QFE
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Reg.exe5.2.3790.2869194,04825-Jan-200710:13IA-64SP1SP1QFE
Wreg.exe5.2.3790.286980,38425-Jan-200710:13x86SP1WOW
Reg.exe5.2.3790.4011194,04825-Jan-200710:17IA-64SP2SP2QFE
Wreg.exe5.2.3790.401180,38425-Jan-200710:17x86SP2WOW
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Reg.exe5.2.3790.2869122,88025-Jan-200710:13x64SP1SP1QFE
Wreg.exe5.2.3790.286980,38425-Jan-200710:13x86SP1WOW
Reg.exe5.2.3790.4011122,88025-Jan-200710:17x64SP2SP2QFE
Wreg.exe5.2.3790.401180,38425-Jan-200710:17x86SP2WOW

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kberrmsg, kbwinserv2003postsp2fix, kbexpertiseinter, kbbug, kbfix, kbHotfixServer, kbqfe, KB931633

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Article Info
Article ID : 931633
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 253