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The IAS service stops unexpectedly on a remote RADIUS server that is running Windows Server 2003


View products that this article applies to.

Symptoms

On a Remote Authentication Dial-in User Service (RADIUS) server that is running Microsoft Windows Server 2003, the Internet Authentication Service (IAS) service stops unexpectedly. Then, the following event is logged in the System log:

Event Type: Error
Event Source: Service Control Manager
Event Category: None
Event ID: 7034
Description:
The Internet Authentication Service service terminated unexpectedly.

Additionally, the Isasam.log file contains the following information:
State attribute is present, but unrecognized.
This problem occurs if the following conditions are true:
  • An end-user logs on to the client computer by using a user principal name (UPN).
  • The 802.1X settings on the client computer do not match the remote access policy on the RADIUS server. For example, the client computer uses Extensible Authentication Protocol-Transport Layer Security (EAP-TLS) for 802.1X authentication. But the RADIUS server requires Protected EAP (PEAP) for 802.1X authentication.
  • The RADIUS client reuses an outdated State attribute during RADIUS authentication.

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Cause

This problem occurs because the RADIUS client sends an EAP Identity packet that has the State attribute applied. This State attribute is created for a previous conversation that has already been rejected by the IAS service. Then, the RADIUS client sends a negative acknowledgement (NAK) packet to the RADIUS server. An access violation occurs when the IAS service incorrectly processes the NAK packet.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Iassam.dll5.2.3790.2897133,12009-Mar-200712:48x86SP1SP1QFE
Windows Server 2003 with Service Pack 2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Iassam.dll5.2.3790.4038133,12009-Mar-200712:33x86SP2SP2QFE
Windows Server 2003 with Service Pack 1, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Iassam.dll5.2.3790.2897426,49608-Mar-200721:04IA-64SP1SP1QFE
Wiassam.dll5.2.3790.2897133,12008-Mar-200721:04x86SP1WOW
Windows Server 2003 with Service Pack 2, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Iassam.dll5.2.3790.4038427,00808-Mar-200721:09IA-64SP2SP2QFE
Wiassam.dll5.2.3790.4038133,12008-Mar-200721:09x86SP2WOW
Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Iassam.dll5.2.3790.2897213,50408-Mar-200721:04x64SP1SP1QFE
Wiassam.dll5.2.3790.2897133,12008-Mar-200721:04x86SP1WOW
Windows Server 2003 with Service Pack 2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Iassam.dll5.2.3790.4038213,50408-Mar-200721:09x64SP2SP2QFE
Wiassam.dll5.2.3790.4038133,12008-Mar-200721:09x86SP2WOW

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbwinserv2003postsp2fix, kbexpertiseinter, kbbug, kbfix, kbhotfixserver, kbqfe, kbpubtypekc, KB931533

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Article Info
Article ID : 931533
Revision : 9
Created on : 10/11/2007
Published on : 10/11/2007
Exists online : False
Views : 323