Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The Windows NT User Data Migration Tool (Shmgrate.exe) may crash when a user logs on to a server that is running an x64-based version of Windows Server 2003


View products that this article applies to.

Symptoms

The Windows NT User Data Migration Tool (Shmgrate.exe) may crash when a user logs on to a server that is running an x64-based version of Microsoft Windows Server 2003.

This problem occurs when a user logs on to the server by using a profile that was created in an earlier version of Windows Server 2003. The profile may be a local profile or a roaming profile.

↑ Back to the top


Cause

This problem occurs because the Shmgrate.exe process accesses an incorrect memory address.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Shell32.dll6.0.3790.288110,503,16813-Feb-200718:06x64SP1Not Applicable
W03a2409.dll5.2.3790.288128,16013-Feb-200718:06x64SP1Not Applicable
Wshell32.dll6.0.3790.28818,384,51213-Feb-200718:06x86SP1WOW
Ww03a2409.dll5.2.3790.288127,64813-Feb-200718:06x86SP1WOW
Windows Server 2003 with Service Pack 2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Shell32.dll6.0.3790.402210,505,72813-Feb-200718:35x64SP2Not Applicable
W03a2409.dll5.2.3790.4022454,14413-Feb-200718:35x64SP2Not Applicable
Wshell32.dll6.0.3790.40228,359,93613-Feb-200718:35x86SP2WOW
Ww03a2409.dll5.2.3790.4022453,63213-Feb-200718:35x86SP2WOW

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

Call stack information

When this issue occurs, the following call stack is generated.
0:000> k
Child-SP          RetAddr           Call Site
00000000`000afea8 00000001`00006279 SHELL32!FirstUserLogon+0x9d 
00000000`000afeb0 00000001`00006415 shmgrate!HandOffToShell32+0x49 
00000000`000afee0 00000001`0000c441 shmgrate!main+0x175 
00000000`000aff20 00000000`78d5965c shmgrate!mainCRTStartup+0x171 
00000000`000aff80 00000000`00000000 kernel32!BaseProcessStart+0x29

Here are the registry values while the issue is occurring:

0:000> r
rax=0000000000000002 rbx=000007ff7f190000 rcx=00006b5d6a770000
rdx=0000000040000000 rsi=00000000002e60cb rdi=0000000000000000
rip=000007ff7f34f2b9 rsp=00000000000afea8 rbp=00000000002dff00
 r8=00000000000afc00  r9=00000000000afd00 r10=0000000000000409
r11=0000000000000019 r12=0000000000000002 r13=0000000080004005
r14=000000010000f010 r15=0000000000000000
iopl=0         nv up ei pl nz na pe nc
cs=0033  ss=002b  ds=002b  es=002b  fs=0053  gs=002b             efl=00000202
SHELL32!FirstUserLogon+0x9d:
000007ff`7f34f2b9 48ff64c428      jmp     qword ptr [rsp+rax*8+28h] ss:00000000`000afee0=0000000000000003

↑ Back to the top


Keywords: KB931498, kbhotfixserver, kbqfe, kbexpertiseinter, kbautohotfix

↑ Back to the top

Article Info
Article ID : 931498
Revision : 8
Created on : 10/11/2007
Published on : 10/11/2007
Exists online : False
Views : 237