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You do not receive the certificate selection prompt when you use Internet Explorer 6 to connect to a secured Web site that requires a client certificate on a Windows Server 2003 SP1 or SP2-based computer


View products that this article applies to.

Symptoms

You use Microsoft Internet Explorer 6 on a computer that is running Microsoft Windows Server 2003 Service Pack 1 (SP1) or on a computer that is running Windows Server 2003 Service Pack 2 (SP2). You use this computer to connect to a secured Web site that requires a client certificate. However, you do not receive the certificate selection prompt. Additionally, you receive the following error message:
The page cannot be displayed

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Cause

This problem occurs because of a code change that was made in the Schannel.dll file. This file is included in Windows Server 2003 SP1 and in Windows Server 2003 SP2. This change lets the Secure Sockets Layer (SSL) client reconnect to the Web server by using the credentials that are stored in the cache for the current session. The client may have to reconnect if the client receives a request to start a new session. The client may also have to reconnect if the client requests a new session. In this a scenario, Web servers that do not support the SSL client behavior expect a new session to be generated. These Web servers do not expect the client to reconnect by using the credentials that are stored in the cache for the current session. Therefore, you receive the error message when you try to connect to a secured Web site.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1) or Windows Server 2003 Service Pack 2 (SP2) installed on the computer. For more information about how to obtain the latest service pack for Windows Server 2003, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Schannel.dll5.2.3790.2866144,38423-Jan-200710:10x86SP1SP1QFE
Schannel.dll5.2.3790.4008146,94423-Jan-200710:07x86SP2SP2QFE
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Schannel.dll5.2.3790.2866465,40822-Jan-200721:01IA-64SP1SP1QFE
Wschannel.dll5.2.3790.2866144,38422-Jan-200721:01x86SP1WOW
Schannel.dll5.2.3790.4008465,40822-Jan-200721:06IA-64SP2SP2QFE
Wschannel.dll5.2.3790.4008146,94422-Jan-200721:06x86SP2WOW
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Schannel.dll5.2.3790.2866253,95222-Jan-200721:01x64SP1SP1QFE
Wschannel.dll5.2.3790.2866144,38422-Jan-200721:01x86SP1SP1QFE\WOW
Schannel.dll5.2.3790.4008253,95222-Jan-200721:05x64SP2SP2QFE
Wschannel.dll5.2.3790.4008146,94422-Jan-200721:05x86SP2SP2QFE\WOW

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about the description of the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Technical support for x64-based versions of Microsoft Windows

If your hardware came with a Microsoft Windows x64 edition already installed, your hardware manufacturer provides technical support and assistance for the Windows x64 edition. In this case, your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation by using unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with a Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware. If you purchased a Windows x64 edition such as a Microsoft Windows Server 2003 x64 edition separately, contact Microsoft for technical support.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Microsoft Windows Server 2003, visit the following Microsoft Web site:

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Keywords: kbnosurvey, kbarchive, kbautohotfix, kbwinserv2003sp1fix, kbwinserv2003postsp2fix, kbexpertiseinter, kbbug, kbfix, kbHotfixServer, kbqfe, KB931494

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Article Info
Article ID : 931494
Revision : 2
Created on : 1/16/2015
Published on : 1/16/2015
Exists online : False
Views : 328