Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Claims that are added by a "claims transform" module on a Windows Server 2003 SP2-based computer are missing when you switch to a Windows NT token-based application


View products that this article applies to.

Symptoms

Consider the following scenario. In an Active Directory Federation Services (ADFS) environment on a Microsoft Windows Server 2003 Service Pack 2 (SP2)-based computer, certain claims are added by a "claims transform" module. However, these claims are missing when you switch to a Microsoft Windows NT token-based application.

Specifically, when you use a Web browser to access a claims-aware Web application in a resource partner organization, all claims are displayed on the applicable Web page. However, when you access a Windows NT token-based Web application in the same resource partner organization, the claims are not displayed on the applicable Web page. This is true even though you access the Windows NT token-based Web application in the same Web browser window.

↑ Back to the top


Cause

This problem occurs because the claims that are added by the "claims transform" module are not cached correctly on the ADFS server. The claims that are added to the token must be cached for single sign-on access to other Web applications.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 with SP2 installed on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Adfsreg.exe5.2.3790.288015,36012-Feb-200716:34IA-64SP1SP1QFE
System.web.security.singlesignon.dll5.2.3790.2880581,63212-Feb-200716:34x86SP1SP1QFE
Adfsreg.exe5.2.3790.402110,24012-Feb-200716:39IA-64SP2SP2QFE
System.web.security.singlesignon.dll5.2.3790.4021581,63212-Feb-200716:39x86SP2SP2QFE
Updspapi.dll6.3.4.1655,15212-Feb-200716:41IA-64NoneNot Applicable
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Adfsreg.exe5.2.3790.28809,21612-Feb-200716:34x64SP1SP1QFE
System.web.security.singlesignon.dll5.2.3790.2880581,63212-Feb-200716:34x86SP1SP1QFE
Adfsreg.exe5.2.3790.40216,65612-Feb-200716:39x64SP2SP2QFE
System.web.security.singlesignon.dll5.2.3790.4021581,63212-Feb-200716:39x86SP2SP2QFE
Updspapi.dll6.3.4.1462,12812-Feb-200716:41x64NoneNot Applicable
Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Adfsreg.exe5.2.3790.28807,68012-Feb-200711:31x86SP1SP1QFE
System.web.security.singlesignon.dll5.2.3790.2880581,63213-Feb-200705:22x86SP1SP1QFE
Adfsreg.exe5.2.3790.40216,14412-Feb-200712:59x86SP2SP2QFE
System.web.security.singlesignon.dll5.2.3790.4021581,63213-Feb-200705:38x86SP2SP2QFE
Updspapi.dll6.3.4.1379,18427-Dec-200607:40x86NoneNot Applicable

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbautohotfix, kbexpertiseinter, kbwinserv2003postsp2fix, kbbug, kbfix, kbqfe, KB931316

↑ Back to the top

Article Info
Article ID : 931316
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 461