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You may experience increased paging to the hard disk when you run an SAP R/3 program on a Windows Server 2003-based computer


View products that this article applies to.

Symptoms

When you run an SAP R/3 program on a Microsoft Windows Server 2003-based computer, you may experience increased paging to the hard disk. Therefore, you may experience decreased system performance.

Note These paging volumes show an increase when compared to the paging volumes that are generated if you run the same program on a Windows 2000 Server-based computer.

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Cause

In Windows Server 2003, the modified page writer thread is responsible for writing to the page file those pages that have been modified in memory. This modified behavior is designed to make sure that as many pages as possible are available at any particular time. This thread becomes active when a particular number of pages have been modified in memory.

The SAP R/3 program uses many worker process threads. Each of these worker process threads has a particular amount of memory allocated as a working set. Generally, the size of this working set is stable. However, the pages in this working set are frequently modified. This frequent page modification causes the modified page writer thread to write the pages to the hard disk. Therefore, Windows Server 2003 performs excessive paging operations when you run an SAP R/3 program.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must be running Windows Server 2003 Service Pack 2 (SP2) or Windows Server 2003 Service Pack 1 (SP1) to apply this hotfix. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003
Important This hotfix is designed specifically for Windows Server 2003 SP2 and for Windows Server 2003 SP1. This hotfix is not designed for any later service packs that may be released for Windows Server 2003.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, 32-bit x86 editions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntkrnlmp.exe5.2.3790.29192,460,16018-Apr-200711:58Not ApplicableSP1SP1QFE
Ntkrnlpa.exe5.2.3790.29192,272,25618-Apr-200711:14x86SP1SP1QFE
Ntkrpamp.exe5.2.3790.29192,312,70418-Apr-200711:13Not ApplicableSP1SP1QFE
Ntoskrnl.exe5.2.3790.29192,420,73618-Apr-200711:57x86SP1SP1QFE
Ntkrnlmp.exe5.2.3790.40632,469,88818-Apr-200712:50Not ApplicableSP2SP2QFE
Ntkrnlpa.exe5.2.3790.40632,282,49618-Apr-200711:54x86SP2SP2QFE
Ntkrpamp.exe5.2.3790.40632,321,92019-Apr-200713:21Not ApplicableSP2SP2QFE
Ntoskrnl.exe5.2.3790.40632,430,46418-Apr-200712:49x86SP2SP2QFE
Windows Server 2003, 64-bit x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntkrnlmp.exe5.2.3790.29174,631,04017-Apr-200706:42x64SP1SP1QFE
Ntoskrnl.exe5.2.3790.29174,487,68017-Apr-200706:42x64SP1SP1QFE
Ntkrnlmp.exe5.2.3790.40614,569,08817-Apr-200706:45x64SP2SP2QFE
Ntoskrnl.exe5.2.3790.40614,499,96817-Apr-200706:45x64SP2SP2QFE
Windows Server 2003, 64-bit Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdll.dll5.2.3790.29171,636,86417-Apr-200706:43IA-64SP1SP1QFE
Ntkrnlmp.exe5.2.3790.29176,519,29617-Apr-200706:43IA-64SP1SP1QFE
Ntdll.dll5.2.3790.40611,636,86417-Apr-200706:44IA-64SP2SP2QFE
Ntkrnlmp.exe5.2.3790.40616,535,68017-Apr-200706:44IA-64SP2SP2QFE

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

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Keywords: kbautohotfix, kbwinservperf, kbbug, kbfix, kbhotfixserver, kbqfe, kbpubtypekc, KB931308

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Article Info
Article ID : 931308
Revision : 9
Created on : 10/11/2007
Published on : 10/11/2007
Exists online : False
Views : 262