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Error message when you attach a device that loads the Serscan.sys driver to a computer that is running Windows Server 2003 Service Pack 2: "STOP: 0x000000c9 DRIVER_VERIFIER_IOMANAGER_VIOLATION"


View products that this article applies to.

Symptoms

When you attach a device that loads the Serial Scanner driver (Serscan.sys) to a computer that is running Microsoft Windows Server 2003 Service Pack 2 (SP2), you experience the following problems:
  • Your computer automatically restarts.
  • After you log on to the computer, you receive an error message that resembles the following:
    Microsoft Windows
    The system has recovered from a serious error.
    A log of this error has been created.
    Please tell Microsoft about this problem.
    We have created an error report that you can send to help us improve Microsoft Windows. We will treat this report as confidential and anonymous.
    To see what data this error report contains, click here.
    If the error message remains on the screen, and if you want to see the data that the error report contains, click click here at the bottom of the message box. When you click this button, signature information appears. This signature information resembles the following:
    BCCode : 000000c9 BCP1 : 0000021f BCP2 : f1958e80 BCP3 : 87c10f00 BCP4 : 00000000 OSVer : 5_2_3718 SP : 0_0 Product : 272_3
  • The computer may stop responding. Additionally, you may receive a Stop error message on a blue screen. The error message resembles the following:
    A problem has been detected and Windows has been shut down to prevent damage to your computer...
    Technical information:

    *** STOP: 0x000000c9 (0x0000021f, 0xf1958e80, 0x87c10f00, 0x00000000)
    DRIVER_VERIFIER_IOMANAGER_VIOLATION
    This problem may occur when the Driver Verifier utility is turned on.

Notes

  • The results of a Stop error message vary according to the computer's system failure settings.
  • The parameters that are in the error signature information (BCP x), and the parameters that are inside the parentheses of the technical information for the Stop error message, may vary according to the computer's configuration.

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Cause

This problem occurs because the DriverEntry function in the Serscan.sys driver does not fill in the IRP_MJ_SYSTEM_CONTROL I/O request packet (IRP) dispatch routine that is checked by the Driver Verifier utility.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 with SP2 installed on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Serscan.sys5.2.3790.286222,01616-Jan-200705:58IA-64SP1SP1QFE
Serscan.sys5.2.3790.400622,01616-Jan-200706:00IA-64SP2SP2QFE
Updspapi.dll6.3.4.1655,15216-Jan-200706:02IA-64NoneNot Applicable
Windows Server 2003 and Windows XP, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Serscan.sys5.2.3790.286211,77616-Jan-200705:56x64SP1SP1QFE
Serscan.sys5.2.3790.400611,77616-Jan-200705:59x64SP2SP2QFE
Updspapi.dll6.3.4.1462,12816-Jan-200706:03x64NoneNot Applicable
Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Serscan.sys5.2.3790.28629,21616-Jan-200710:59x86SP1SP1QFE
Serscan.sys5.2.3790.40069,21616-Jan-200714:25x86SP2SP2QFE
Updspapi.dll6.3.4.1379,18427-Dec-200607:40x86NoneNot Applicable

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

The Driver Verifier utility may be turned on when the Device Test Manager (DTM) is used to perform the driver reliability tests. The driver reliability tests include the following:
  • Device Path Exerciser test
  • Common Scenario Stress With IO test
  • Sleep Stress With IO test
  • Disable Enable With IO test
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kberrmsg, kbbluescreen, kbwinserv2003postsp2fix, kbexpertiseadvanced, kbbug, kbfix, kbhotfixserver, kbqfe, KB931301

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Article Info
Article ID : 931301
Revision : 3
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 429