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On a Windows Server 2003-based computer that is running Internet Information Services 6.0, the Inetinfo.exe process may close unexpectedly when a failover occurs in a cluster environment


View products that this article applies to.

Symptoms

On a Microsoft Windows Server 2003-based computer that is running Microsoft Internet Information Services (IIS) 6.0, the Inetinfo.exe process may close unexpectedly when a failover occurs in a cluster environment. The following event may be logged in the Application log:
Event Type:	Error
Event Source:	Application Error
Event Category:	(100)
Event ID:	1000
Description:
Faulting application inetinfo.exe, version 6.0.3790.1830, faulting module unknown, version 0.0.0.0, fault address 0x63ec8952.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 41 70 70 6c 69 63 61 74   Applicat
0008: 69 6f 6e 20 46 61 69 6c   ion Fail
0010: 75 72 65 20 20 69 6e 65   ure  ine
0018: 74 69 6e 66 6f 2e 65 78   tinfo.ex
0020: 65 20 36 2e 30 2e 33 37   e 6.0.37
0028: 39 30 2e 31 38 33 30 20   90.1830 
0030: 69 6e 20 75 6e 6b 6e 6f   in unkno
0038: 77 6e 20 30 2e 30 2e 30   wn 0.0.0
0040: 2e 30 20 61 74 20 6f 66   .0 at of
0048: 66 73 65 74 20 36 33 65   fset 63e
0050: 63 38 39 35 32            c8952

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Cause

This issue occurs because the Inetinfo.exe process prematurely unloads the Isatq.dll file from the address space. After the Inetinfo.exe process unloads the Isatq.dll file, any reference to the Isatq.dll file in the Inetinfo.exe process causes an access violation.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1) installed on the computer.

For more information about how to obtain the latest service pack for Windows Server 2003, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Isatq.dll6.0.3790.286072,19211-Jan-200702:08x64

Windows Server 2003 with Service Pack 1, IA-64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Isatq.dll6.0.3790.2860142,84811-Jan-200702:11IA-64

Windows Server 2003 with Service Pack 1, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Isatq.dll6.0.3790.286052,73611-Jan-200717:43x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbwinserv2003sp2fix, kbexpertisebeginner, kbqfe, kbhotfixserver, KB930952

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Article Info
Article ID : 930952
Revision : 8
Created on : 10/11/2007
Published on : 10/11/2007
Exists online : False
Views : 215