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Error message when you try to open one of the Microsoft Dynamics CRM entities on the computer that is running the Microsoft Dynamics CRM 3.0 client for Outlook: "The address list could not be displayed. The action could not be completed"


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Symptoms

When you try to open one of the Microsoft Dynamics CRM entities on the computer that is running the Microsoft Dynamics CRM 3.0 client for Microsoft Office Outlook, you receive the following error message:
The address list could not be displayed. The action could not be completed.
Additionally, the following error message is logged in the Application log every time that Microsoft Dynamics CRM 3.0 synchronizes with Outlook:
Event Type: Error
Event Source: MSCRMAddressBook
Event Category: None
Event ID: 6403
Date: date
Time: time
User: N/A
Computer:computer_name
Description: An error occurred initializing a synchronization of the Microsoft CRM Address Book. Check the user credentials and network connection and restart Microsoft Outlook. HR=0x80040220. Context=OnlineSync. Function=COnlineSync::GetSyncChanges. Line=162.

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Cause

This issue may occur if you use a custom security role where access to the address book has been modified.

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Resolution

To resolve this issue, add the Read permission to the custom security role for the Queue entity and for the Facility/Equipment entity. To do this, follow these steps:
1.Click Settings, click Settings, click Business Unit Settings, click Security Roles, and then double-click the custom security role.
2.On the Core Records tab, click to select the Read check box to add the Read permission for the Queue entity.
3.On the Service Management tab, click to select the Read check box to add the Read permission for the Facility/Equipment entity.
4.Click Save and Close.
If you cannot add the Read permission to the custom security role for the Queue entity and for the Equipment entity, change the synchronization of the Queue entity and of the Facility/Equipment entity to the address book. To do this, download hotfix 925780 and then follow the steps in the "Registry keys that are created by the hotfix" section.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
925780 The address book provider for the Microsoft Dynamics CRM client for Outlook may take several hours to synchronize if there are many records in entities in Microsoft Dynamics CRM 3.0
Note To change the synchronization of the Queue entity and of the Facility/Equipment entity, modify the following registry entry names so that they have a value of 0:
ABPEquipment
ABPQueue

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Keywords: KB930793, kbprb, kbmbsmigrate, kbmsccsearch, kberrmsg, kbexpertisebeginner, kbtshoot

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Article Info
Article ID : 930793
Revision : 3
Created on : 3/21/2007
Published on : 3/21/2007
Exists online : False
Views : 375