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Error message when you start an application on an App-V or SoftGrid Client: "A network operation did not complete in time. Error code: 0A-10000005"


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Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows registry

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Symptoms

When you start an application on an App-V or SoftGrid client, the operation is unsuccessful. Additionally, you receive the following error message: 

A network operation did not complete in time. Please check your network connection and try again. If the problem persists, please report the following error code to your System Administrator.
Error code: xxxxxx-xxxxxx0A-10000005

Additionally, the following error code is logged in the client log file (Sftlog.txt):

The SoftGrid client could not connect to stream URL 'protocol://server_name:port/path/filename.sft' (FS status: xxxxxx0A-10000005).
The client was unable to connect to a SoftGrid server (rc xxxxxx0A-10000005)

Additionally, the following error code may be logged in the server log file (Sft-server.log): 

41515 "Invalid OPTIONS request: Invalid protocol version."
41515 "Invalid OPTIONS request: Invalid query string."

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Cause

This issue can be caused by:
  • The HREF path in the .osd file contains a space.
  • The ?Customer= element in the .osd file does not contain the question mark (?) or the equal sign (=) characters.
  • The App-V or SoftGrid client timed out.

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Resolution

To resolve this issue, use one or more of the following methods, as appropriate for your situation.

Method 1: Edit the HREF path in the .osd file

The HREF attribute of the CODEBASE element of the .osd file may contain a space. In this case, edit the .osd file by using a text editor such as Notepad to replace the space with %20.


For example, find the following text in the .osd file:
HREF="rtsp://%SFT_SOFTGRIDSERVER%:554/Softricity SFTs/DefaultApp.sft"
Replace this text with the following text:
HREF="rtsp://%SFT_SOFTGRIDSERVER%:554/Softricity%20SFTs/DefaultApp.sft"

Method 2: Edit the ?Customer= element in the .osd file

The ?Customer= element that is specified in the HREF attribute of the CODEBASE element of the .osd file may not contain the question mark (?) or the equal sign (=) characters. In this case, edit the .osd file by using a text editor such as Notepad to correct the syntax.


For example, find the following text in the .osd file:
HREF="rtsp://%SFT_SOFTGRIDSERVER%:554/DefaultApp.sftCustomerAnonymous"
Replace this text with the following text:
HREF="rtsp://%SFT_SOFTGRIDSERVER%:554//DefaultApp.sft?Customer=Anonymous"

Method 3: Modify the time-out interval value

By default, the App-V and SoftGrid client ReadTimeout registry value is configured to be 20 seconds. You may have to increase this value.  

Note The time-out interval should not exceed 30 seconds.

To modify the value, follow these steps.

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.
  1. Click Start, click Run, type regedit in the Open box, and then click OK.
  2. Expand the appropriate registry subkey for your client version: 
    Softgrid: HKEY_LOCAL_MACHINE\SOFTWARE\Softricity\SoftGrid Client\CurrentVersion\Network
    App-V x86:HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SoftGrid\4.5\Client\Network
    App-V x64: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\SoftGrid\4.5\Client\Network
  3. Right-click ReadTimeout, and then click Modify.
  4. For Base, select Decimal.
  5. For Value data, type the number of seconds that you want, and then click OK.
  6. Exit Registry Editor.
Note You must restart the Application Virtualization Client or SoftGrid Client service for this change to take effect.

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Keywords: kb, kbexpertiseinter, kbtshoot, kbacqcompany

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Article Info
Article ID : 930697
Revision : 2
Created on : 3/27/2020
Published on : 3/27/2020
Exists online : False
Views : 437