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Error message when the SoftGrid Client tries to start an application: "Error code: xxxxxx-xxxxxx0A-20000194"


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Symptoms

The Microsoft SoftGrid Client tries to start an application. However, the attempt is not successful, and you receive an error message that resembles the following:
The SoftGrid Client could not launch <application_name>.
The package requested could not be found in the system data store or the files associated with this package could not be found on the server. Please report the following error code to your System Administrator.
Error code: xxxxxx-xxxxxx0A-20000194
An entry that resembles the following may appear in the SoftGrid Client log file (Sftlog.txt):
An entry that resembles the following may appear in the SoftGrid Virtual Application Server log file (Sft-server.log):

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Cause

This behavior can occur if one or more of the following conditions are true:
  • You are trying to start a SoftGrid-enabled application that has not been added to the SoftGrid Management Console.
  • The .sft file that is specified in the .osd file does not exist within the content directory structure.
  • The path or the .sft file name that is specified in the Softricity File Relative Path entry is invalid.
  • The Provider Policy that is specified in the .osd file does not exist.

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Resolution

The following information provides resolutions for each cause that is mentioned in the "Cause" section.
  • You are trying to start a SoftGrid-enabled application that has not been added to the SoftGrid Management Console

    There are two conditions under which you can try to successfully start a SoftGrid-enabled application that has not been added to the SoftGrid Management Console:
    • You double-click the .osd file of a SoftGrid-enabled application.
    • You double-click the shortcut of a SoftGrid-enabled application that has been removed from SoftGrid Client Management.

      Note The shortcut is not removed when the SoftGrid-enabled application is removed from SoftGrid Client Management. The shortcut is not removed if you manually copy the shortcut to an alternative location when the application is added to SoftGrid Client Management. When the application is later removed, SoftGrid Client Management is unaware of the alternative location, and the shortcut is not removed.
  • The .sft file that is specified in the .osd file does not exist within the content directory structure

    The .sft file does not exist within the content directory structure. This .sft file is specified in the HREF attribute of the CODEBASE element of the .osd file.

    Consider the following scenario. The .osd file is configured as in the following example:
    HREF="rtsp://%SFT_SOFTGRIDSERVER%:554/Softricity/sft_ea70.v1.sft"
    The content directory is configured as in the following example path:
    C:\Program Files\Softricity\SoftGrid Server\content
    In this scenario, Microsoft SoftGrid cannot start the application if the sft_ea70.v1.sft file does not exist in the Softricity subdirectory in the following content directory path:
    C:\Program Files\Softricity\SoftGrid Server\content\Softricity
    .
  • The path or the .sft file name that is specified in the "Softricity File Relative Path" is invalid

    The Softricity File Relative Path must only contain the subdirectory of the content directory and the .sft file name. For example, the .sft file name is example.sft and exists within the Example Applications subdirectory of the content directory. If the content directory is C:\Program Files\Softricity\SoftGrid Server\content, the Softricity File Relative Path is Example Applications\example.sft. If the content directory is \\SERVERNAME\content, the Softricity File Relative Path is still Example Applications\example.sft.

    To verify that the Relative Path only contains the subdirectory of the content directory and the .sft file name, follow these steps: steps:
    1. From Administrative Tools, start SoftGrid Management Console.
    2. Expand SoftGrid Systems<server_name> Packages <package version of the application that does not start> .
    3. Double-click the package version of the application that does not start.
    4. Verify that the Softricity File Relative Path only contains the subdirectory of the content directory and the .sft file name.
  • The Provider Policy that is specified in the .osd file does not exist

    The Provider Policy that ?Customer= specifies does not exist. This Provider Policy is specified in the HREF attribute of the CODEBASE element of the .osd file

    Consider the following scenario. Your SoftGrid environment has multiple Provider Policies such as the Default Provider and a custom Provider Policy that is named Anonymous. Additionally, you have to configure an .osd file to use the Anonymous Provider Policy. In this scenario, the .HREF attribute of the CODEBASE element of the .osd file must appear as in the following example.

    HREF="rtsp://%SFT_SOFTGRIDSERVER%:554/Softricity/sft_ea70.v1.sft?Customer=Anonymous"
    Note If the Provider Policy name that follows ?Customer= does not exist, Microsoft SoftGrid cannot start the application.

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Article Info
Article ID : 930614
Revision : 1
Created on : 1/7/2017
Published on : 7/9/2012
Exists online : False
Views : 334