Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

"Crystal Print Engine Error 723" when you try to print or to preview a custom report in Microsoft Dynamics SL


View products that this article applies to.

Symptoms

When you try to print or to preview a custom report in Microsoft Dynamics SL, you receive an error message that resembles the following message:
Cannot start print job.
Report: C:\Program Files\Solomon\Usr_Rpts\CUSTOM.RPT
Crystal Print Engine Error: 723 - Error in File
C:\Program Files\Solomon\Usr_Rpts\CUSTOM.RPT: Failed to open a rowset.
This problem occurs if the following conditions are true:
  • The custom report contains a parameter field.
  • You type the appropriate value when the report prompts you for a parameter.
  • You specify additional selection criteria on the Select tab in the Report Options Interpreter (ROI) screen.

↑ Back to the top


Cause

This problem occurs because the Report Options Interpreter (ROI) screen incorrectly concatenates the WHERE clauses that are in the selection criteria and in the parameter field.

↑ Back to the top


Workaround

To work around this problem, do not include the parameter field in the custom report. Instead, create the parameter selection criteria on the Select tab of the Report Options Interpreter (ROI) screen.

↑ Back to the top


Keywords: kberrmsg, kbmbspartner, kbexpertisebeginner, kbtshoot, kbmbsmigrate, kbprb, kbsurveynew, kb

↑ Back to the top

Article Info
Article ID : 930445
Revision : 2
Created on : 2/2/2017
Published on : 2/3/2017
Exists online : False
Views : 163