Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The Type is “Not Defined” if you add an Extender field as a column in a SmartList object in Microsoft Dynamics GP


View products that this article applies to.

Symptoms

If you add an Extender field as a column in a SmartList object that is linked to an Extender window, the Type value of the SmartList object is Not Defined in Microsoft Dynamics GP.

↑ Back to the top


Cause

This issue occurs because one or more of the following conditions are true:
  • The SmartList objects are damaged and must be repaired.
  • The link is removed for the Extender window that is linked to a SmartList object.
  • The Extender window is deleted, and then an Extender window that has the same field names is created.
This issue also occurs because Extender is company-specific, but SmartList is not company-specific.

↑ Back to the top


Resolution

To resolve this issue, follow these steps:
  1. In the main Microsoft Dynamics GP company, click Tools, click Extender, and then click Options.
  2. Click to select the Auto-update SmartLists check box.
  3. In all companies other than the main company, click to clear the Auto-update SmartLists check box.
    Note In this step, include any test companies that you may have created.
  4. In all companies, remove the SmartList link from all Extender windows that are linked to a SmartList object.
  5. In the main company, open SmartList.
  6. Click Extras, click Additional, and then click Extender.
  7. Click the SmartList object that had the Type value of Not Defined.
  8. Click the first Extender field in the Extender Fields area, and then click the red X to delete the field.
  9. Repeat step 8 for all Extender fields.
  10. Exit and then start Microsoft Dynamics GP.
  11. Open the main company.
  12. Link the Extender window to the SmartList object again.
  13. Open SmartList, click Extras, click Additional, and then click Extender. Verify that you see the Extender field in the list only one time.

    Note If you do not see any Extender fields, exit and then start Microsoft Dynamics GP.

↑ Back to the top


More Information

All SmartList modifications must be made in the main company in Microsoft Dynamics GP for the program to work correctly. Therefore, we recommend that you put any Extender window in the main company even if you do not intend to use that Extender window.

↑ Back to the top


References

For more information about how to use multiple companies when you add Extender window fields to a SmartList object, click the following article number to view the article in the Microsoft Knowledge Base:

914170 Guidelines for adding fields to SmartList from Extender in Microsoft Great Plains

↑ Back to the top


Keywords: kbexpertiseadvanced, kbexpertiseinter, kbmbspartner, kbmbsmigrate, kbprb, kb

↑ Back to the top

Article Info
Article ID : 930053
Revision : 1
Created on : 1/7/2017
Published on : 7/18/2012
Exists online : False
Views : 182