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Error messages when you use a CDO application that is updated to the latest CDO library to log on to an Exchange 2003 server: "(0x8004011D) The server is not available" or "MAPI_E_NOT_FOUND (0x8004010F)"


View products that this article applies to.

Symptoms

You update a Collaboration Data Objects (CDO) application to the latest CDO library. However, you cannot use the CDO application to log on to a server that is running Microsoft Exchange Server 2003. If you turn on diagnostic logging of the Exchange store on an Exchange 2003 server, the MAPI_E_FAILONEPROVIDER error or the MAPI_E_NOT_FOUND error is logged in the Application log. Additionally, the client may display one of the following error messages:
  • (0x8004011D) The server is not available
  • MAPI_E_NOT_FOUND (0x8004010F)
Note 0x8004011D maps to the MAPI_E_FAILONEPROVIDER error.

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Cause

This problem occurs if the latest Cdo.dll starts to pass a CONNECT_IGNORE_NO_PF flag to the Exchange 2003 server. This flag was introduced in Microsoft Exchange Server 2007. However, Exchange 2003 does not recognize the flag.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Because of file dependencies, Microsoft Exchange Server 2003 Service Pack 2 (SP2) must be installed on the server before you apply this hotfix. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart your computer after you apply this hotfix. However, the following services are automatically restarted when you apply the hotfix:
  • Microsoft Exchange Information Store service
  • Microsoft Search service
  • IIS Admin Service and all dependent services

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Exosal.dll6.5.7652.970,14413-Jan-200709:06x86
Mdbmsg.dll6.5.7652.93,375,10413-Jan-200708:21x86
Store.exe6.5.7652.95,263,36013-Jan-200709:10x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: KB929751, kbhotfixserver, kbexchdev, kbexpertiseinter, kbqfe, kbautohotfix

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Article Info
Article ID : 929751
Revision : 5
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 248