Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You may experience increased paging to the hard disk when you run an SAP R/3 program on a Windows Server 2003-based computer


View products that this article applies to.

Symptoms

When you run an SAP R/3 program on a Microsoft Windows Server 2003-based computer, you may experience increased paging to the hard disk. Therefore, you may experience decreased performance.

Note These paging volumes show an increase when they are measured against the paging volumes that are generated if you run the same program on a Microsoft Windows 2000 Server-based computer.

↑ Back to the top


Cause

This problem occurs because, in Windows Server 2003, the modified page writer thread is responsible for writing to the page file those pages that have been modified in memory. This modified behavior is designed to make sure that as many pages as possible are available at any particular time. This thread becomes active when a particular number of pages have been modified in memory.

The SAP R/3 program uses many worker process threads. Each of these worker process threads has a particular amount of memory allocated as a working set. Generally, the size of this working set is stable. However, the pages in this working set are frequently modified. This frequent page modification causes the modified page writer thread to write the pages to the hard disk. Therefore, Windows Server 2003 performs excessive paging operations when you run the SAP R/3 program.

↑ Back to the top


Resolution

This hotfix has been superseded by another hotfix. For more information about the new hotfix, click the following article number to view the article in the Microsoft Knowledge Base:
931308 You may experience increased paging to the hard disk when you run an SAP R/3 program on a Windows Server 2003-based computer

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

↑ Back to the top


Keywords: kbbug, kbfix, kbqfe, KB929620

↑ Back to the top

Article Info
Article ID : 929620
Revision : 3
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 263