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The host (A) record is not deleted after you delete a name server (NS) record in Windows Server 2003 or in Windows 2000


View products that this article applies to.

Symptoms

After you delete a name server (NS) resource record in the DNS Management Console, the host (A) record is not deleted. However, the DNS pointer (PTR) resource record for the A record is deleted as expected.

You notice this problem when you reopen the DNS Management Console or when you use the shortcut menu to reload the zone.

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Cause

This problem occurs if the NS resource record that you try to delete points to a fully qualified domain name (FQDN) outside the zone. This problem occurs even when the DNS is authoritative for the zone.

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Workaround

To work around this problem, manually delete the host (A) record in the DNS Management Console.

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More information

Steps to reproduce the problem
1.Add two forward lookup zones to a DNS server. Name the zones adatum.com and contoso.com.
2.Add the 10.in-addr.arpa reverse lookup zone to the DNS zone.
3.Add an a.contoso.com host record that uses IP address 10.11.12.13.
4.Add the corresponding PTR resource record to the 10.in-addr.arpa zone.
5.Add an additional NS record for a.contoso.com to the adatum.com zone. Then, make sure that the NS record points to the a.contoso.com record.
6.Delete the NS resource record in the DNS Management console.
7.If you receive a message that resembles the following, click Yes:
Do you want to delete the host record <FQDN of host record><IP address of host record>?

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: kbexpertiseinter, kbprb, kberrmsg, kbtshoot, KB929588

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Article Info
Article ID : 929588
Revision : 3
Created on : 10/11/2007
Published on : 10/11/2007
Exists online : False
Views : 234