Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Error message when you try to start the TAPI service on a Windows Server 2003-based computer that is joined to a domain: "No Call Appearance Available"


View products that this article applies to.

Symptoms

When you try to start the Telephony Application Programming Interface (TAPI) service on a Microsoft Windows Server 2003-based computer that is joined to a domain, you receive the following error message:
No Call Appearance Available

↑ Back to the top


Cause

This issue occurs if the account for the computer that you are using does not have the appropriate permissions to write to the container that is listed for that computer under the domain. For example, the container for the computer may be displayed as follows in the ADSI Edit snap-in:
CN=Computer_name

↑ Back to the top


Resolution

To resolve this issue, use the ADSI Edit snap-in to set the appropriate permission for the computer account. To do this, follow these steps.

Note The ADSI Edit snap-in is included in the Windows Server 2003 support tools that are provided on the Windows Server 2003 CD. To install the Windows Server 2003 support tools, run the Suptools.msi file from the SUPPORT\TOOLS folder on the Windows Server 2003 CD.Warning If you use the ADSI Edit snap-in, the LDP utility, or any other LDAP version 3 client, and you incorrectly modify the attributes of Active Directory objects, you can cause serious problems. These problems may require you to reinstall Microsoft Windows 2000 Server, Microsoft Windows Server 2003, Microsoft Exchange 2000 Server, Microsoft Exchange Server 2003, or both Windows and Exchange. Microsoft cannot guarantee that problems that occur if you incorrectly modify Active Directory object attributes can be solved. Modify these attributes at your own risk.
  1. Click Start, click Run, type Adsiedit.msc in the Open box, and then click OK.
  2. In the ADSI Edit snap-in, expand the Domain node.
  3. Locate and then expand the CN=Computers container node.
  4. Locate and then right-click the container node for the computer object that you want, and then click Properties.
  5. In the computer object properties dialog box, click the Security tab.
  6. On the Security tab, click Add.
  7. In the Enter the object names to select box, type SYSTEM, and then click OK.
  8. Click to select the Allow check box next to the Create All Child Objects permission, and then click OK.
  9. On the File menu, click Exit to close the ADSI Edit snap-in.
  10. Try to start the TAPI service again.

↑ Back to the top


Keywords: KB929273, kbtshoot, kbexpertiseadvanced

↑ Back to the top

Article Info
Article ID : 929273
Revision : 2
Created on : 1/3/2007
Published on : 1/3/2007
Exists online : False
Views : 201