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You experience errors in an application that uses Common Log File System (CLFS) API functions in Windows Server 2003 R2


View products that this article applies to.

Symptoms

You experience one or more of the following symptoms in an application that uses Common Log File System (CLFS) API functions on a computer that is running Microsoft Windows Server 2003 R2.

Symptom 1

When a log is full, the application moves the log file to a different location to free disk space. If the log file cannot be moved, the application receives an exception that does not provide a reason why the log file cannot be moved. Therefore, the application crashes.

Symptom 2

The application receives an exception that indicates an error code 38 (ERROR_HANDLE_EOF). The error code is received if the application performs the following tasks:
  • Calls the SetEndOfLog function to truncate the log before a restart area
  • Enumerates this restart area

Symptom 3

When the application is trying to enumerate the records, the application receives the following error message:
Start LSN invalid
This symptom typically occurs if the application creates multiple streams in a log file, and then the application appends interleaving records in the log file.

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Cause

Some CLFS API functions do not work correctly in certain scenarios.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2003 R2 on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 R2, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Clfs.sys5.2.3790.2842204,28830-Nov-200610:40x86SP1
Clfs.sys5.2.3790.2842204,28830-Nov-200610:40x86SP1
Clfsw32.dll5.2.3790.284278,84830-Nov-200617:48x86SP1
Clfs.sys5.2.3790.2842204,28830-Nov-200610:40x86SP1
Clfsw32.dll5.2.3790.284278,84830-Nov-200617:48x86SP1
Clfs.sys5.2.3790.2842204,28830-Nov-200610:40x86SP1
Clfsw32.dll5.2.3790.284278,84830-Nov-200617:48x86SP1
Windows Server 2003 R2, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Clfs.sys5.2.3790.2842772,09630-Nov-200602:13IA-64SP1SP1QFE
Clfsw32.dll5.2.3790.2842316,92830-Nov-200602:14IA-64SP1SP1QFE
Clfs.sys5.2.3790.2842772,09630-Nov-200602:14IA-64SP1SP1QFE
Clfs.sys5.2.3790.2842772,09630-Nov-200602:14IA-64SP1SP1QFE
Updspapi.dll6.2.29.0638,68830-Nov-200602:19IA-64NoneNot Applicable
Windows Server 2003 R2, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Clfs.sys5.2.3790.2842366,08030-Nov-200602:16x64SP1
Clfsw32.dll5.2.3790.2842105,98430-Nov-200602:16x64SP1
Clfs.sys5.2.3790.2842366,08030-Nov-200602:16x64SP1
Clfs.sys5.2.3790.2842366,08030-Nov-200602:16x64SP1
Clfs.sys5.2.3790.2842366,08030-Nov-200602:16x64SP1

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseinter, kbwinserv2003postsp2fix, kbbug, kbfix, kbhotfixserver, kbqfe, KB929219

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Article Info
Article ID : 929219
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 480