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After you�restore a sparse file on a Windows Server 2003-based computer that has antivirus software enabled, data is lost


View products that this article applies to.

Symptoms

On a Microsoft Windows Server 2003-based computer, you can back up and restore a sparse file by using a backup program. However, if an antivirus program is running, a large sparse file may be damaged after you restore it.

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Cause

A backup program closes the sparse file during the restore operation. Then, an antivirus program opens the sparse file as a section file to check whether it includes virus patterns. When the antivirus program calls the ZwCreateSection function, a timing issue occurs between the following operations:
  • The delayed write operation that is requested by the file close action
  • The flush cache operation that is requested by the antivirus program
In this scenario, the NTFS file system driver incorrectly sets the valid data length of the sparse file to a value that is smaller than the actual size of the file. Therefore, any attempt to read the data that is beyond the incorrect valid data length returns all zeros.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1) or Windows Server 2003 Service Pack 2 (SP2) installed. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with SP2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntkrnlmp.exe5.2.3790.40772,492,41609-May-200712:32Not ApplicableSP2SP2QFE
Ntkrnlpa.exe5.2.3790.40772,304,00009-May-200711:42x86SP2SP2QFE
Ntkrpamp.exe5.2.3790.40772,343,93609-May-200711:41Not ApplicableSP2SP2QFE
Ntoskrnl.exe5.2.3790.40772,452,48009-May-200712:32x86SP2SP2QFE
Windows Server 2003 with SP2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Hal.dll5.2.3790.4077280,06409-May-200713:11x64SP2SP2QFE
Ntkrnlmp.exe5.2.3790.40774,591,61609-May-200713:11x64SP2SP2QFE
Ntoskrnl.exe5.2.3790.40774,521,98409-May-200713:11x64SP2SP2QFE
Windows Server 2003 with SP2, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdll.dll5.2.3790.40771,636,86409-May-200713:10IA-64SP2SP2QFE
Ntkrnlmp.exe5.2.3790.40776,559,74409-May-200713:10IA-64SP2SP2QFE
Windows Server 2003 with SP1, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntkrnlmp.exe5.2.3790.29332,463,23209-May-200711:53Not ApplicableSP1SP1QFE
Ntkrnlpa.exe5.2.3790.29332,275,32809-May-200711:14x86SP1SP1QFE
Ntkrpamp.exe5.2.3790.29332,315,77609-May-200705:04Not ApplicableSP1SP1QFE
Ntoskrnl.exe5.2.3790.29332,423,29609-May-200711:52x86SP1SP1QFE
Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Hal.dll5.2.3790.2933280,06409-May-200712:59x64SP1SP1QFE
Ntkrnlmp.exe5.2.3790.29334,635,13609-May-200712:59x64SP1SP1QFE
Ntoskrnl.exe5.2.3790.29334,490,24009-May-200712:59x64SP1SP1QFE
Windows Server 2003 with SP1, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdll.dll5.2.3790.29331,636,86409-May-200712:59IA-64SP1SP1QFE
Ntkrnlmp.exe5.2.3790.29336,524,41609-May-200712:59IA-64SP1SP1QFE

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Workaround

To work around this problem, configure the antivirus program to exclude the�sparse files when the program scans for viruses.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about the terms that are used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseinter, kbwinserv2003postsp2fix, kbbug, kbfix, kbhotfixserver, kbqfe, kbpubtypekc, KB929020

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Article Info
Article ID : 929020
Revision : 6
Created on : 10/11/2007
Published on : 10/11/2007
Exists online : False
Views : 235