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The Volume Shadow Copy Service crashes on Windows Server 2003-based computers that are using non-page 80 SCSI devices


View products that this article applies to.

Symptoms

The Windows Volume Shadow Copy Service (VSS) crashes on Windows Server 2003-based computers that use non-page 80 SCSI devices.

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Cause

The Scsiport driver reads the serial number to complete the STORAGE_DEVICE_DESCRIPTOR structure from the SCSI Inquiry page 0x80. For devices that do not support inquiry page 0x80, such as smart controller devices, the Scsiport driver sets the STORAGE_DEVICE_DESCRIPTOR.SerialNumberOffset field to -1 (0xFFFFFFFF).

The VSS Service expects the STORAGE_DEVICE_DESCRIPTOR.SerialNumberOffset value to be set to 0 if the device does not have a serial number.

The problem occurs because the offset is converted implicitly to size_t. Size_t is 64-bit. This does not cause an arithmetic overflow because a memory buffer of size 0xffffffff is possible on these platforms.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, the computer must be running one of the following operating systems:
  • A 32-bit version of Windows Server 2003 with Service Pack 1 (SP1)
  • An Itanium-based version of Windows Server 2003 with SP1
  • An x64-based version of Windows

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Eventcls.dll5.2.3790.283831,23222-Nov-200612:25x86SP1
Ftdisk.sys5.2.3790.2838137,21622-Nov-200609:43x86SP1
Partmgr.sys5.2.3790.283825,08822-Nov-200610:15x86SP1
Swprv.dll5.2.3790.2838275,96822-Nov-200612:25x86SP1
Volsnap.sys5.2.3790.2838154,11222-Nov-200609:43x86SP1
Vssadmin.exe5.2.3790.2838134,14422-Nov-200609:43x86SP1
Vssapi.dll5.2.3790.2838561,66422-Nov-200612:25x86SP1
Vssui.dll5.2.3790.2838144,38422-Nov-200612:25x86SP1
Vssvc.exe5.2.3790.2838836,09622-Nov-200609:43x86SP1
Vss_ps.dll5.2.3790.283819,45622-Nov-200612:25x86SP1
Updspapi.dll6.2.29.0371,42412-Oct-200523:13x86SP1
Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Eventcls.dll5.2.3790.283846,08022-Nov-200613:59x64SP1
Ftdisk.sys5.2.3790.2838240,12822-Nov-200613:59x64SP1
Partmgr.sys5.2.3790.283845,05622-Nov-200613:59x64SP1
Swprv.dll5.2.3790.2838656,89622-Nov-200613:59x64SP1
Volsnap.sys5.2.3790.2838289,79222-Nov-200613:59x64SP1
Vss_ps.dll5.2.3790.283825,60022-Nov-200613:59x64SP1
Vssadmin.exe5.2.3790.2838245,24822-Nov-200613:59x64SP1
Vssapi.dll5.2.3790.28381,320,96022-Nov-200614:00x64SP1
Vssvc.exe5.2.3790.28382,062,33622-Nov-200614:00x64SP1
Wvss_ps.dll5.2.3790.283819,45622-Nov-200614:00x86SP1
Wvssapi.dll5.2.3790.2838561,66422-Nov-200614:00x86SP1
Windows Server 2003, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Eventcls.dll5.2.3790.283882,43222-Nov-200613:55IA-64SP1
Ftdisk.sys5.2.3790.2838498,68822-Nov-200613:55IA-64SP1
Partmgr.sys5.2.3790.283883,45622-Nov-200613:55IA-64SP1
Swprv.dll5.2.3790.2838832,51222-Nov-200613:55IA-64SP1
Volsnap.sys5.2.3790.2838478,20822-Nov-200613:55IA-64SP1
Vss_ps.dll5.2.3790.283831,23222-Nov-200613:55IA-64SP1
Vssadmin.exe5.2.3790.2838313,85622-Nov-200613:55IA-64SP1
Vssapi.dll5.2.3790.28381,640,44822-Nov-200613:55IA-64SP1
Vssvc.exe5.2.3790.28382,586,11222-Nov-200613:55IA-64SP1
Wvss_ps.dll5.2.3790.283819,45622-Nov-200613:56x86SP1
Wvssapi.dll5.2.3790.2838561,66422-Nov-200613:56x86SP1

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows Server 2003 Service Pack 2.

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More information

For more information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915� New file naming schema for Microsoft Windows software update packages
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates


Technical support for x64-based versions of Microsoft Windows

If your hardware came with a Microsoft Windows x64 edition already installed, your hardware manufacturer provides technical support and assistance for the Windows x64 edition. In this case, your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation by using unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with a Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware. If you purchased a Windows x64 edition such as a Microsoft Windows Server 2003 x64 edition separately, contact Microsoft for technical support.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Microsoft Windows Server 2003, visit the following Microsoft Web site:

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Keywords: kbautohotfix, kbwinserv2003sp2fix, kbfix, kbbug, kbhotfixserver, kbqfe, kbprb, kbexpertiseadvanced, KB928599

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Article Info
Article ID : 928599
Revision : 11
Created on : 10/11/2007
Published on : 10/11/2007
Exists online : False
Views : 251