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Error message when you save an "Asset Book" record in Microsoft Dynamics GP: “A save operation on table ‘FA_ASSET_MSTR’ failed accessing SQL


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SYMPTOMS

When you save an Asset Book record in Microsoft Dynamics GP, you receive the following error message:

     A save operation on table ‘FA_ASSET_MSTR’ failed accessing SQL data

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CAUSE

This problem occurs because data in the following tables are corrupted:

• Fixed Asset Index
• Fixed Asset Activity
• Dex_lock
• Dex_session
• Activity

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RESOLUTION

To resolve this problem, clear the tables that are listed in the "Cause" section. To do this, follow these steps:
1. Have all users exit Microsoft Dynamics GP.
2.

Start the Support Administrator Console, Microsoft SQL Query Analyzer, or SQL Server Management Studio. To do this, use one of the following methods depending on the program that you are using:

• If you are using SQL Server Desktop Engine (also known as MSDE 2000), start the Support Administrator Console. To do this, click Start , point to All Programs , point to Microsoft Administrator Console , and then click Support Administrator Console .

• If you are using SQL Server 2000, start SQL Query Analyzer. To do this, click Start , point to All Programs , point to Microsoft SQL Server , and then click Query Analyzer .

• If you are using SQL Server 2005, start SQL Server Management Studio. To do this, click Start , point to All Programs , point to Microsoft SQL Server 2005 , and then click SQL Server Management Studio .



     
3. Run the following script against the DYNAMICS database.
Delete ACTIVITY 
4. Run the following scripts against the TEMPDB database.
Delete DEX_LOCK
Delete DEX_SESSION 
5. Run the following scripts against the company database.
Delete FAINDEX
Delete FA01500 
6. Log on to Microsoft Dynamics GP as the sa user, and then access Fixed Assets. To do this, point to Fixed Assets on the Cards menu, and then click General .

Note When you access Fixed Assets as the sa user, the FAINDEX table will be reinitialized.
7. Verify that you do not receive the error message that is mentioned in the "Symptoms" section. To do this, follow these steps:
a. On the Cards menu, point to Fixed Assets , and then click Book .
b. Display an Asset Book record, and then click Save .

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Keywords: kbExpertiseInter, kbExpertiseBeginner, kbEntireNet, kberrmsg, kbprb, kbMBSPartner, BemisKB928533, kbMBSMigrate, kbnosurvey, kb, kbtshoot

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Article Info
Article ID : 928533
Revision : 1
Created on : 3/1/2017
Published on : 3/1/2017
Exists online : False
Views : 233