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A third-party backup program may ignore one or more local disk drives during a backup operation on a Windows Server 2003-based computer that is running the Cluster service


View products that this article applies to.

Symptoms

On a Microsoft Windows Server 2003-based computer that is running the Cluster service, a third-party backup program may ignore one or more local disk drives during a backup operation. This problem occurs if the following conditions are true:
  • Windows Server 2003 Service Pack 1 or hotfix 894394 is applied. For more information about hotfix 894394, click the following article number to view the article in the Microsoft Knowledge Base:
    894394� A program that calls the ClusterResourceControl function may run slowly on a Windows Server 2003 cluster-based computer
  • A cluster disk that was previously available is unavailable.

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Cause

This problem occurs because of an error in the ClusterResourceControl function. In order to retrieve information for a specific cluster disk, the backup program calls this function by using the CLUSCTL_RESOURCE_STORAGE_GET_DISK_INFO control code. However, when the cluster disk is unavailable, the function incorrectly returns a drive letter that is used for a local non-cluster disk. Therefore, a local disk is mistaken for a cluster disk. If the program is configured to back up only local disks, the local disks that are mistaken for cluster disks are ignored.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2 installed. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 2, 32-bit (x86-based) versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Clusres.dll5.2.3790.4003481,28010-Jan-200712:56x86SP2
W03a2409.dll5.2.3790.4003453,63209-Jan-200715:56x86SP2
Windows Server 2003 with Service Pack 2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Clusres.dll5.2.3790.4004655,36011-Jan-200721:46x64SP2Not Applicable
W03a2409.dll5.2.3790.4004454,14411-Jan-200721:46x64SP2Not Applicable
Ww03a2409.dll5.2.3790.4004453,63211-Jan-200721:46x86SP2WOW
Windows Server 2003 with Service Pack 2, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Clusres.dll5.2.3790.40031,168,38410-Jan-200700:23IA-64SP2Not Applicable
W03a2409.dll5.2.3790.4003452,60810-Jan-200700:23IA-64SP2Not Applicable
Ww03a2409.dll5.2.3790.4003453,63210-Jan-200700:23x86SP2WOW
Windows Server 2003 with Service Pack 1, 32-bit (x86-based) versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Clusres.dll5.2.3790.2859481,28010-Jan-200713:24x86SP1
W03a2409.dll5.2.3790.285927,13609-Jan-200713:10x86SP1
Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Clusres.dll5.2.3790.2860655,36011-Jan-200720:07x64SP1Not Applicable
W03a2409.dll5.2.3790.286027,64811-Jan-200720:07x64SP1Not Applicable
Ww03a2409.dll5.2.3790.286027,13611-Jan-200720:07x86SP1WOW
Windows Server 2003 with Service Pack 1, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Clusres.dll5.2.3790.28591,168,38409-Jan-200722:04IA-64SP1Not Applicable
W03a2409.dll5.2.3790.285926,11209-Jan-200722:04IA-64SP1Not Applicable
Ww03a2409.dll5.2.3790.285927,13609-Jan-200722:04x86SP1WOW

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about the CLUSCTL_RESOURCE_STORAGE_GET_DISK_INFO control code, visit the following Microsoft Developer Network (MSDN) Web site: For more information about the terms that are used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbexpertiseinter, kbwinserv2003postsp2fix, kbbug, kbfix, kbhotfixserver, kbqfe, kbpubtypekc, kbautohotfix, KB928385

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Article Info
Article ID : 928385
Revision : 9
Created on : 7/24/2007
Published on : 7/24/2007
Exists online : False
Views : 295