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You cannot open an InfoPath document by clicking a hyperlink when Internet Explorer 6 is installed on a Windows XP-based or on a Windows Server 2003-based computer


View products that this article applies to.

Symptoms

You click a hyperlink to open a Microsoft Office InfoPath document on a computer that has Microsoft Internet Explorer 6 installed. However, you cannot open the InfoPath document. This problem occurs if the computer is running one of the following operating systems:
  • Microsoft Windows XP
  • Microsoft Windows Server 2003

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Cause

This problem occurs because of an error in Internet Explorer 6. When you click a hyperlink to open an InfoPath document, Internet Explorer 6 calls the ShellExecute function to create an InfoPath process. The Internet Explorer process may exit before the ShellExecute function finishes creating the InfoPath process. Therefore, you cannot open the InfoPath document as expected.

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Resolution

Windows XP

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
To apply the hotfix, you must have Microsoft Windows XP Service Pack 2 (SP2) installed on the computer.
Restart requirement
You do not have to restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other previously released hotfixes.
Registry information
To use one of the hotfixes in this package, you do not have to make any changes to the registry.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows XP with SP2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Shdocvw.dll6.0.2900.30381,498,11220-Nov-200613:20x86

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Windows Server 2003

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
To apply the hotfix, you must have Microsoft Windows Server 2003 Service Pack 1 (SP1) installed on the computer.
Restart requirement
You do not have to restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other previously released hotfixes.
Registry information
To use one of the hotfixes in this package, you do not have to make any changes to the registry.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2003 with SP1, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Shdocvw.dll6.0.3790.28361,515,52020-Nov-200608:15x86
Windows Server 2003 with SP1, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Shdocvw.dll6.0.3790.28362,438,65619-Nov-200616:30x64SP1Not Applicable
Wshdocvw.dll6.0.3790.28361,515,52019-Nov-200616:30x86SP1WOW
Windows Server 2003 with SP1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Shdocvw.dll6.0.3790.28363,680,76819-Nov-200616:30IA-64SP1Not Applicable
Wshdocvw.dll6.0.3790.28361,515,52019-Nov-200616:30x86SP1WOW

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbexpertisebeginner, kbqfe, kbHotfixServer, KB928248

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Article Info
Article ID : 928248
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 275