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The status of a dynamic volume unexpectedly changes to "Online (Error)" after the system detects bad blocks on a Windows Server 2003-based computer


View products that this article applies to.

Symptoms

On a Microsoft Windows Server 2003-based computer, the status of a dynamic volume unexpectedly changes to "Online (Error)" after the system detects bad blocks. In this situation, you cannot create a software mirror.

Additionally, events that resemble the following are logged in the System event log:

Event ID 29

Event Type: Information
Event Source: dmio
Event Category: None
Event ID: 29
Computer: <Computer>
Description: dmio: Harddisk1 read error at block <Number>: status <Error code>

Event ID 26

Event Type: Information
Event Source: dmio
Event Category: None
Event ID: 26
Computer: <Computer>
Description: dmio: Found a bad block on disk <Disk name> at block number <Number>

Event ID 23

Event Type: Information
Event Source: dmio
Event Category: None
Event ID: 23
Computer: <Computer>
Description: dmio: Reassigning bad block number <Number> on disk <Disk name>

Event ID 24

Event Type: Information
Event Source: dmio
Event Category: None
Event ID: 24
Computer: <Computer>
Description: dmio: Reassign bad block(s) on disk <Disk name> succeeded

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Cause

This problem occurs because of an error in the Dmio.sys module. The Dimo.sys module does not process bad blocks correctly as specified in the "SCSI Sector Sparing" technology specifications. Therefore, some reassignment requests fail unexpectedly. The disk status changes to "Online (Error)" if the reassignment fails.

Note This hotfix corrects only the reassignment problem. The disk status still changes to "Online (Error)" even if the reassignment is successful. Therefore, you need to reactivate the disk manually.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2 installed on the computer. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Dmio.sys5.2.3790.2954150,52812-Jun-200711:12x86
Windows Server 2003 with Service Pack 2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Dmio.sys5.2.3790.4098150,52812-Jun-200711:30x86
Windows Server 2003 with Service Pack 1, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Dmio.sys5.2.3790.2954535,04012-Jun-200705:28IA-64
Windows Server 2003 with Service Pack 2, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Dmio.sys5.2.3790.4098535,04012-Jun-200705:33IA-64
Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Dmio.sys5.2.3790.2954244,22412-Jun-200705:28x64
Windows Server 2003 with Service Pack 2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Dmio.sys5.2.3790.4098244,22412-Jun-200705:31x64
Note The disk status changed to "Online (Error)" even if the reassignment is successful.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

SCSI disks support the SCSI Sector Sparing technology. If the system detects a bad block, the system automatically tries to map defective blocks to new locations on the disk. The disk status remains healthy if the reassignment is successful. The disk status changes to "Online (Error)" if the reassignment fails. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
325615� Cannot create software mirror if disk contains bad blocks
For more information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseinter, kbwinserv2003postsp2fix, kbbug, kbfix, kbhotfixserver, kbqfe, kbpubtypekc, KB928124

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Article Info
Article ID : 928124
Revision : 7
Created on : 10/26/2007
Published on : 10/26/2007
Exists online : False
Views : 303