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FIX: The Esent.dll file is replaced by an incorrect version of the Esent.dll file, after you apply hotfix 910437 on a Windows Server 2003-based computer that has ADAM already installed


View products that this article applies to.

Symptoms

Consider the following scenario. On a Microsoft Windows Server 2003-based computer, you have already installed Active Directory Application Mode (ADAM) on the operating system. Then you apply the hotfix that is described in Microsoft Knowledge Base article 910437. After you find that the Esent.dll file is replaced with an incorrect version of the Esent.dll file.

Note The Esent.dll file is located in the following path: <drive> :\<systemroot>\system32\ADAM\

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Cause

This problem occurs because there is an issue in the Setup program of hotfix 910437.

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Resolution

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have the hotfix that is described in KB article 910437 installed on your computer to apply this hotfix. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
910437 When Windows Automatic Updates tries to download updates on a Windows Server 2003-based or Windows XP-based computer, an access violation error may occur

Restart Requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel. Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Esent.dll5.2.3790.4311,054,72025-Oct-200501:54x86
Windows Server 2003 with SP1, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Esent.dll5.2.3790.25551,046,52825-Oct-200501:57x86
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Esent.dll5.2.3790.25552,366,97607-Nov-200618:42x64SP1Not Applicable
Wesent.dll5.2.3790.25551,046,52807-Nov-200618:42x86SP1WOW
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Esent.dll5.2.3790.4312,604,54407-Nov-200618:31IA-64
Windows Server 2003 with SP1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Esent.dll5.2.3790.25552,775,55207-Nov-200618:41IA-64SP1Not Applicable
Wesent.dll5.2.3790.25551,046,52807-Nov-200618:41x86SP1WOW

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.

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More information

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseinter, kbwinserv2003presp2fix, kbfix, kbhotfixserver, kbqfe, KB927775

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Article Info
Article ID : 927775
Revision : 8
Created on : 10/11/2007
Published on : 10/11/2007
Exists online : False
Views : 212