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FIX: Memory usage of the Spoolsv.exe process may increase over time when you use a shared printer in Windows Server 2003 to print documents (927744.KB.EN-US.1.0)


View products that this article applies to.

Symptoms

Consider the following scenario. You print documents on a Windows Server 2003 Service Pack 1 (SP1)-based computer, by using a shared printer. The memory usage of the Spoolsv.exe process increases over time. Eventually, the Spoolsv.exe process may consume lots of memory. This problem usually occurs several months after the Printer Spooler service has been running on a Windows Server 2003 Service Pack 1 (SP1)-based computer.

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Cause

Every time that a print job is sent to a shared printer from a Windows Server 2003 SP1-based computer, a small memory leak occurs in the Print Spooler service.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1) installed on the computer. For more information about how to obtain the latest service pack for Windows Server 2003, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Restart Requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix Replacement Information

This hotfix does not replace any other hotfixes.

File Information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Spoolss.dll5.2.3790.282487,55202-Nov-200613:33x86

Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Spoolss.dll5.2.3790.2824253,95201-Nov-200622:05IA-64

Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Spoolss.dll5.2.3790.2824167,93601-Nov-200622:05x64

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Workaround

You may work around this problem by restarting the Print Spooler service regularly. To do this, run the following command at a command prompt.
Net stop spooler && Net start spooler

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article. This problem was first corrected in Microsoft Windows Server 2003 Service Pack 2.

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Keywords: kbautohotfix, kbwinserv2003sp2fix, kbwinserv2003presp2fix, kbexpertiseinter, kbbug, kbfix, kbqfe, KB927744

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Article Info
Article ID : 927744
Revision : 3
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 278