Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The heavy use of Winsock programs may exhaust the system's non-paged pool memory in Windows Server 2003


View products that this article applies to.

Symptoms

Under certain circumstances in Microsoft Windows Server 2003, the heavy use of Winsock programs may exhaust the system's non-paged pool memory. This behavior is likely to occur if the Winsock program is dealing with both Out-of-Band (MSG_OOB) traffic and standard TCP traffic. In this situation, you may experience various error messages and poor performance. Additionally, the system may stop responding (hang).

↑ Back to the top


Cause

If the Winsock program does not read the incoming data from Winsock, the AfdB pool tag may buffer more data than is optimal. This behavior may exhaust all available non-paged pool memory.

↑ Back to the top


Resolution

This update has been superseded by another update. For more information about the replacement fix, click the following article number to view the article in the Microsoft Knowledge Base:
931311 The heavy use of Winsock programs may exhaust the "nonpaged pool memory" of a Windows Server 2003-based computer

↑ Back to the top


Workaround

To work around this issue, do not use MSG_OOB data in the Winsock program. Use a separate socket for urgent data.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915 New file naming schema for Microsoft Windows software update packages
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Technical support for x64-based versions of Microsoft Windows

If your hardware came with a Microsoft Windows x64 edition already installed, your hardware manufacturer provides technical support and assistance for the Windows x64 edition. In this case, your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation by using unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with a Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware. If you purchased a Windows x64 edition such as a Microsoft Windows Server 2003 x64 edition separately, contact Microsoft for technical support.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Microsoft Windows Server 2003, visit the following Microsoft Web site:

↑ Back to the top


Keywords: kbwinserv2003presp2fix, kbfix, kbbug, kbhotfixserver, kbqfe, kbprb, kbexpertiseadvanced, KB927493

↑ Back to the top

Article Info
Article ID : 927493
Revision : 8
Created on : 10/11/2007
Published on : 10/11/2007
Exists online : False
Views : 270