Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A Windows Server 2003-based domain controller may restart unexpectedly when it handles an LDAP query


View products that this article applies to.

Symptoms

When a Windows Server 2003-based domain controller handles a Lightweight Directory Access Protocol (LDAP) query, you may receive the following error message on the domain controller, and the domain controller may automatically restart:
The system is shutting down. Please save all work in progress and log off. Any unsaved changes will be lost. This shutdown was initiated by NT AUTHORITY\SYSTEM.

Time before shutdown: 00:00:30

The system process 'C:\WINDOWS\system32\lsass.exe' terminated unexpectedly with status code ErrorCode. The system will now shut down and restart.
When this problem occurs, the following event is logged in the Application log:

Type: Error
Source: Winlogon
Event Category: None
Event ID: 1015
Date: Date
Time: Time
User: N/A
Computer: ComputerName
Description:
A critical system process, C:\WINDOWS\system32\lsass.exe, failed with status code c0000005. The machine must now be restarted.

↑ Back to the top


Cause

This problem occurs if the domain controller incorrectly manages the search duplicate buffer. In this situation, the Lsass.exe process may stop unexpectedly.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2 installed. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 2, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Ntdsa.dll5.2.3790.41431,495,55201-Sep-200708:19x86SP2
W03a2409.dll5.2.3790.4106453,63228-Jun-200707:33x86SP2
Windows Server 2003 with Service Pack 2, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdsa.dll5.2.3790.41432,721,79201-Sep-200707:44x64SP2Not applicable
W03a2409.dll5.2.3790.4082454,14401-Sep-200707:44x64SP2Not applicable
Wntdsa.dll5.2.3790.41431,495,55201-Sep-200707:44x86SP2WOW
Ww03a2409.dll5.2.3790.4106453,63201-Sep-200707:44x86SP2WOW
Windows Server 2003 with Service Pack 2, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdsa.dll5.2.3790.41434,081,66401-Sep-200707:44IA-64SP2Not applicable
W03a2409.dll5.2.3790.4082452,60801-Sep-200707:44IA-64SP2Not applicable
Wntdsa.dll5.2.3790.41431,495,55201-Sep-200707:44x86SP2WOW
Ww03a2409.dll5.2.3790.4106453,63201-Sep-200707:44x86SP2WOW
Windows Server 2003 with Service Pack 1, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Ntdsa.dll5.2.3790.30021,524,22401-Sep-200707:22x86SP1
W03a2409.dll5.2.3790.295728,67218-Jun-200704:31x86SP1
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdsa.dll5.2.3790.30022,968,06401-Sep-200707:17x64SP1Not applicable
W03a2409.dll5.2.3790.295729,18401-Sep-200707:18x64SP1Not applicable
Wntdsa.dll5.2.3790.30021,524,22401-Sep-200707:18x86SP1WOW
Ww03a2409.dll5.2.3790.295728,67201-Sep-200707:18x86SP1WOW
Windows Server 2003 with Service Pack 1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdsa.dll5.2.3790.30024,257,28001-Sep-200707:18IA-64SP1Not applicable
W03a2409.dll5.2.3790.295727,64801-Sep-200707:18IA-64SP1Not applicable
Wntdsa.dll5.2.3790.30021,524,22401-Sep-200707:18x86SP1WOW
Ww03a2409.dll5.2.3790.295728,67201-Sep-200707:18x86SP1WOW

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbautohotfix, kbexpertiseinter, kbwinserv2003postsp2fix, kbbug, kbfix, kbHotfixServer, kbqfe, KB927342

↑ Back to the top

Article Info
Article ID : 927342
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 260