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A client computer that is running Windows XP or Windows Server 2003 may lose connectivity when it tries to renew its DHCP lease


View products that this article applies to.

Symptoms

A Dynamic Host Configuration Protocol (DHCP) client computer that uses static routes may lose connectivity when the scope subnet mask is modified on the DHCP server.

This problem may occur only when a client computer that is running Microsoft Windows XP or Microsoft Windows Server 2003 tries to renew its DHCP lease.

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Cause

This problem occurs because the static routes are not updated correctly when the client computer renews its IP address.

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Resolution

Hotfix information

Note This problem is fixed in the original release version of Windows Vista.

Windows Server 2003

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
No prerequisites are required.
Restart requirement
You must restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2003, x86-based (32-bit) versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Dhcpcsvc.dll5.2.3790.2869117,24826-Jan-200700:02x86
Updspapi.dll6.2.29.0371,42412-Oct-200523:15x86
Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Dhcpcsvc.dll5.2.3790.2869225,79225-Jan-200710:47x64SP1SP1QFE
Wdhcpcsvc.dll5.2.3790.2869117,24825-Jan-200710:47x86SP1WOW
Updspapi.dll6.2.29.0462,04825-Jan-200710:48x64NoneNot Applicable
Windows Server 2003, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Dhcpcsvc.dll5.2.3790.2869308,22425-Jan-200710:47IA-64SP1SP1QFE
Wdhcpcsvc.dll5.2.3790.2869117,24825-Jan-200710:47x86SP1WOW
Updspapi.dll6.2.29.0638,68825-Jan-200710:48IA-64NoneNot Applicable

Windows XP

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
No prerequisites are required.
Restart requirement
You must restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Dhcpcsvc.dll5.1.2600.3052112,12820-Dec-200613:55x86
Updspapi.dll6.2.29.0371,42419-Jan-200619:29x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

Technical support for x64-based versions of Microsoft Windows

If your hardware came with a Microsoft Windows x64 edition already installed, your hardware manufacturer provides technical support and assistance for the Windows x64 edition. In this case, your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation by using unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with a Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware. If you purchased a Windows x64 edition such as a Microsoft Windows Server 2003 x64 edition separately, contact Microsoft for technical support.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Microsoft Windows Server 2003, visit the following Microsoft Web site: For more information about the terms that are used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbwinxpsp3fix, kbwinxppresp3fix, kbwinserv2003presp2fix, kbexpertiseadvanced, kbbug, kbfix, kbHotfixServer, kbqfe, KB927288

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Article Info
Article ID : 927288
Revision : 3
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 293