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FIX: You may experience connectivity problems when you run Host Integration Server 2004 and Host Integration Server 2000 client applications on multi-homed computers


View products that this article applies to.

Symptoms

You may experience connectivity problems when you run the following types of applications on Microsoft Host Integration Server 2000 or Microsoft Host Integration 2004 multi-homed client computers:
  • Advanced Program-to-Program Communications (APPC)-based applications
  • 3270 emulator-based applications
These connectivity problems may occur over time if the following conditions are true:
  • The SnaBase service is not periodically restarted.
  • Host Integration Server has the Named Pipe transport disabled.
The specific symptoms that you experience depend on the type of client that you are running. For example, if you run a Transaction Integrator (TI) application, the following Error event may be logged in the Application log:

Event Type: Error
Event Source: COMTI
Event Category: General
Event ID: 102
Date: Date
Time: Time
User: UserName
Computer: ComputerName
Description: (102) Transaction Integrator reported the following exception to the client:

Component: ComponentName
Method: MethodName

Exception description: (1407) The COM Transaction Integrator LU 6.2 transport failed to allocate a conversation. Do not retry until status of host LU < > is corrected.

If you collect a full internal trace for the SnaBase service on the multi-homed client computer that is experiencing this problem, connection failure information appears in the trace. The following trace information shows that failed connection attempts are incorrectly targeted back to the client computer itself instead of to the Host Integration Server computer.
Destination is REMOTE
Using ltab 03A90104, index 1 for pipe
Release shrmutx before calling OpenConnection
Opening a connection to service 2717 srvtyp =27
Local 65, Remote 65
Starting from transport 1, dwPriority 0
Found common transport 1, type 64
Trying transport 1, type 64
Local address: 0.0.0.0:1290
Trying to connect to: 192.168.244.33:0
connect() failed, error 10049
Trying to connect to: 192.168.244.65:0
connect() failed, error 10049
Trying to connect to: 192.168.244.63:0
connect() failed, error 10049
Trying to connect to: 192.168.244.62:0
connect() failed, error 10049
Trying to connect to: 192.168.244.61:0
connect() failed, error 10049
Trying to connect to: 192.168.244.60:0
connect() failed, error 10049
Trying to connect to: 192.168.244.59:0
connect() failed, error 10049
Trying to connect to: 192.168.244.58:0
   connect() failed, error 10049

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Cause

This problem occurs because the SnaBase service contains logic problems that cause service table entries to be populated incorrectly on multi-homed client computers. The service table entries are populated with the client IP address instead of the server IP address.

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Resolution

Host Integration Server 2000

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Fmistr32.dll5.0.0.210020,75208-Dec-200600:18x86
Mmcsna.dll5.0.0.2100229,64808-Dec-200600:18x86
Mngbase.dll5.0.0.2100151,82408-Dec-200600:18x86
Mngcli.exe5.0.0.2100131,34408-Dec-200600:18x86
Mngext.dll5.0.0.210028,94408-Dec-200600:18x86
Mngsna.dll5.0.0.2100114,96008-Dec-200600:18x86
Nthstreg.dll5.0.0.210028,94408-Dec-200600:18x86
Sec400.dll5.0.0.210053,52008-Dec-200600:18x86
Sechost.dll5.0.0.210053,52008-Dec-200600:18x86
Sfmngext.dll5.0.0.210020,75208-Dec-200600:18x86
Snaadmin.dll5.0.0.2100409,87208-Dec-200600:18x86
Snabase.exe5.0.0.2100282,89608-Dec-200600:18x86
Snacfg.dll5.0.0.2100291,08808-Dec-200600:18x86
Snadmod.dll5.0.0.2100557,32808-Dec-200600:18x86
Snaevent.dll5.0.0.2100483,60008-Dec-200600:18x86
Snahsmsg.dll5.0.0.210078,09608-Dec-200600:18x86
Snaip.dll5.0.0.2100102,67208-Dec-200600:18x86
Snamanag.dll5.0.0.2100184,59208-Dec-200600:18x86
Snancp.dll5.0.0.210020,75208-Dec-200600:18x86
Snanw.dll5.0.0.210065,80808-Dec-200600:18x86
Snaole.dll5.0.0.2100643,34408-Dec-200600:18x86
Snaolewmi.dll5.0.0.2100651,53608-Dec-200600:18x86
Snapage.dll5.0.0.2100512,27208-Dec-200600:18x86
Snarpc.dll5.0.0.2100151,82408-Dec-200600:18x86
Snatrc.dll5.0.0.210098,57608-Dec-200600:18x86
Snatrccn.dll5.0.0.210041,23208-Dec-200600:18x86
Snatrcsn.dll5.0.0.210069,90408-Dec-200600:18x86
Snawiz.dll5.0.0.2100680,20808-Dec-200600:18x86
Snawiz2.dll5.0.0.2100373,00808-Dec-200600:18x86
T3mngext.dll5.0.0.210045,32808-Dec-200600:18x86
T5mngext.dll5.0.0.210045,32808-Dec-200600:18x86
Vstapi.dll5.0.0.210016,65608-Dec-200600:18x86
Wmisna.dll5.0.0.2100483,60008-Dec-200600:18x86
Wmisnastatus.dll5.0.0.210094,48008-Dec-200600:18x86
Wmisnatrace.dll5.0.0.2100164,11208-Dec-200600:18x86
Note Because of file dependencies, the most recent fix that contains these files may also contain additional files.

Host Integration Server 2004

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Snabase.exe6.0.2049.0217,60001-Dec-200600:36x86
Snadmod.dll6.0.2049.0662,01601-Dec-200600:36x86
Snaevent.dll6.0.2049.0472,06401-Dec-200600:36x86
Snaip.dll6.0.2049.099,32801-Dec-200600:36x86
Snalm.dll6.0.2049.050,68801-Dec-200600:36x86
Note Because of file dependencies, the most recent fix that contains these files may also contain additional files.

Host Integration Server 2006

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
32-bit (x86) version
File nameFile versionFile sizeDateTimePlatform
Snaip.dll7.0.2824.0109,91209-Jun-200701:38x86
64-bit (x64) version
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Snaip.dll7.0.2824.0131,41609-Jun-200701:41x64SP1Not Applicable
Snaip.dll7.0.2824.0109,91209-Jun-200701:38x86SP1SYSWOW
Note Because of file dependencies, the most recent fix that contains these files may also contain additional files.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: KB927287, kbqfe, kbHotfixServer, kbbug, kbfix, kbautohotfix

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Article Info
Article ID : 927287
Revision : 3
Created on : 9/23/2011
Published on : 9/23/2011
Exists online : False
Views : 382