Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Error message when you try to upgrade from one version of Microsoft Dynamics CRM to another: "The following indexes are not consistent with Microsoft Dynamics CRM <version> indexes"


View products that this article applies to.

Symptoms

When you try to upgrade from one version of Microsoft Dynamics CRM to another, you may receive error messages, depending on the version of Microsoft Dynamics CRM from which you are upgrading.

Upgrading from Microsoft Dynamics CRM 3.0 to Microsoft Dynamics CRM 4.0

When you try to upgrade from Microsoft Dynamics CRM 3.0 to Microsoft Dynamics CRM 4.0, you receive the following error message in the Environmental Diagnostic Wizard (EDW):
The following indexes are not consistent with Microsoft Dynamics CRM 3.0 indexes
If you open the Crm40svrsetup.log file, you may notice one or more of the following error messages.

Error message 1
Time| Info| The following indexes are not consistent with Microsoft Dynamics CRM 3.0 indexes:
Time|Warning| remark: added index
Time|Warning| tablename: contactbase
Time|Warning| indexname: _dta_index_contactbase_7_693577509__k7_k91_k42_k45_k47_1
Time|Warning| The indexes on the Microsoft Dynamics CRM database are not consistent with Microsoft Dynamics CRM 3.0 indexes.
Error message 2
Action Microsoft.Crm.Setup.InstallDatabaseAction failed. Exception has been thrown by the target of an invocation. Access is denied to "C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\FTData", or the path is invalid.
Error message 3
Error| System.Exception: Action Microsoft.Crm.Setup.Server.InstallDatabaseAction failed. ---> System.Data.SqlClient.SqlException: Cannot alter or drop column 'KeyWords' because it is enabled for Full-Text Search.
The Crm40svrsetup.log file records the installation log that is generated by the Microsoft Dynamics CRM installation. The Crm40svrsetup.log file is located in the following folder:
C:\Documents and Settings\user\Application Data\Microsoft\Mscrm\Logs
Note In this path, user represents the user who is upgrading the program.

If you continue with the upgrade to Microsoft Dynamics CRM 4.0, the upgrade does not work. Additionally, you receive the following error message:
Time| Error| System.Exception: Action Microsoft.Crm.Setup.Server.InstallDatabaseAction failed. ---> System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.Data.SqlClient.SqlException: The index '_dta_index_OrganizationUIBase_7_626101271__K5_K9_1_2_6_10_11_12' is dependent on column 'InProduction'. The statistics '_dta_stat_626101271_2_6' is dependent on column 'InProduction'.
ALTER TABLE ALTER COLUMN InProduction failed because one or more objects access this column.
If you click Retry, the upgrade does not continue. Additionally, you receive the following error message:
Action Microsoft.Crm.Setup.Server.InstallDatabaseAction failed. ---> System.Data.SqlClient.SqlException: There is already an object named 'AttributeTypes' in the database.

Upgrading from Microsoft CRM 1.2 to Microsoft Dynamics CRM 3.0

When you try to upgrade from Microsoft CRM 1.2 to Microsoft Dynamics CRM 3.0, you receive the following error message in the Environmental Diagnostic Wizard (EDW):
The following indexes are not consistent with Microsoft Dynamics CRM 1.2 indexes
In you open the Crm30svrsetup.log file, you may notice one or more of the following error messages:

Error message 1
Microsoft CRM Database The full-text indexes on the Database are not consistent with Microsoft CRM 1.2 full-text indexes.
Error message 2
Time| Info| The following full-text indexes are not consistent with Microsoft CRM 1.2 full-text indexes:
Time| Info| tableowner: dbo
Time| Info| tablename: documentindex
Time| Info| fulltextkeyindexname: pk_documentindex
Time|Warning| remark: modified full-text index
The Crm30svrsetup.log file records the installation log that is generated by the Microsoft Dynamics CRM installation. The Crm30svrsetup.log file is located in the following folder:
C:\Documents and Settings\user\Application Data\Microsoft\Mscrm\Logs
Note In this path, user represents the user who is upgrading the program.

↑ Back to the top


Cause

Upgrading from Microsoft Dynamics CRM 3.0 to Microsoft Dynamics CRM 4.0

This problem occurs because a custom index was added to the Microsoft Dynamics CRM database or because full-text indexing is not working correctly.

Upgrading from Microsoft CRM 1.2 to Microsoft Dynamics CRM 3.0

This problem occurs because you have rebuilt full-text indexing on the Microsoft CRM 1.2 database and have modified the catalog.

↑ Back to the top


Resolution

Upgrading from Microsoft Dynamics CRM 3.0 to Microsoft Dynamics CRM 4.0

To resolve this problem, follow these steps if you receive an error message in the EDW:
  1. Exit the EDW.
  2. Drop the custom indexes from the Microsoft Dynamics CRM 3.0 database. The custom indexes are listed in the Crm40svrsetup.log file.

    Note For more information about how to drop the custom indexes, view the related topic in SQL Server Books Online.
  3. Upgrade to Microsoft Dynamics CRM 4.0.

    Note You should not receive an error message in the EDW.
  4. Add the custom indexes to the Microsoft Dynamics CRM 4.0 database.
If you ignore the error message in the EDW and then receive the "InstallDatabaseAction failed" error message during the upgrade to Microsoft Dynamics CRM 4.0, follow these steps:
  1. Restore the system back to Microsoft Dynamics CRM 3.0. Make sure that the restoration includes the Microsoft Dynamics CRM databases.
  2. Drop the custom indexes from the Microsoft Dynamics CRM 3.0 databases. The custom indexes are listed in the Crm40svrsetup.log file.

    Note For more information about how to drop the custom indexes, view the related topic in SQL Server Books Online.
  3. Upgrade to Microsoft Dynamics CRM 4.0.

    Note You should not receive an error message in the EDW.
  4. Add the custom indexes to the Microsoft Dynamics CRM 4.0 database.
If the problem remains, you must reconfigure full-text indexing. To do this, follow these steps:

Step 1: Restore the system back to Microsoft Dynamics CRM 3.0

  1. Uninstall Microsoft Dynamics CRM 4.0. To do this, follow these steps:
    1. Click Start, point to Control Panel, and then click Add or Remove Programs.
    2. Click Microsoft Dynamics CRM Server, and then click Remove.
  2. Make sure that the Microsoft Dynamics CRM files are removed, if the files still exist then delete the files. These are normally found under <drive:>\Program Files\Microsoft Dynamics CRM.
  3. Delete the Microsoft Dynamics CRM 4.0 databases that are created by the upgrade process. To do this, follow these steps:
    1. Open Microsoft SQL Server Management Studio.
    2. Expand Databases.
    3. Right-click Organization_Name_MSCRM, and then click Delete.
    4. Right-click MSCRM_CONFIG, and then click Delete.
  4. Restore the following Microsoft Dynamics CRM 3.0 databases.

    Note You backed up these databases before you upgraded to Microsoft Dynamics CRM 4.0.
    • Organization_Name_MSCRM
    • Organizaton_Name_Metabase
  5. If you do not have the product key in another location, obtain the product key from the license table. To do this, run the following query in SQL Server Management Studio against the Organization_Name_MSCRM database:
    Select licensekey from license
    
  6. Reinstall Microsoft Dynamics CRM 3.0 by using the Connect to existing databases option. To do this, follow these steps:
    1. Run the Microsoft Dynamics CRM 3.0 Setup program.
    2. When you are prompted to enter a product key, enter the product key that you obtained in step 5.
    3. Click Add, and then click Next.
    4. Enter the name of the server that is running SQL Server, and then click Connect to existing databases.
    5. Complete the installation.

Step 2: Enable full-text indexing

  1. Open SQL Server Management Studio, expand Databases, expand the Organization_Name_MSCRM database, expand Storage, and then expand Full Text Catalogs.
  2. Verify that there is no full-text catalog that is named ftcat_documentindex.
  3. Right-click Full Text Catalogs, and then click New Full-Text Catalog.
  4. In the Full-Text catalog name field, type ftcat_documentindex.
  5. In the Catalog location list, select drive:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\FTData.
  6. In the Filegroup list, make sure that Default appears, and then click OK.
  7. Right-click the ftcat_documentindex full-text catalog that you created in steps 3 through 5, and then click Properties.
  8. Click Tables/Views.
  9. In the All eligible table/view objects in this database section, click to select dbo.documentindex, and then click the arrow to move the selected item to the Table/view objects assigned to the catalog section.
  10. In the Available Columns list, click to select the following check boxes:
    • KeyWords
    • SearchText
    • Title
  11. In the Language for Word Breakers list, click to select the check box for the correct language word breaker.
  12. Click OK.
  13. Run the following query in SQL Server Management Studio against the Organization_Name_MSCRM database:
    EXEC sp_fulltext_database 'enable'
    GO
    
  14. Right-click the Organization_Name_MSCRM database, and then click Properties.
  15. Click Files, and then verify that the Use full-text indexing option is selected.

Upgrading from Microsoft CRM 1.2 to Microsoft Dynamics CRM 3.0

To resolve this problem, follow these steps:
  1. Remove full-text indexing from the DocumentIndex table. To do this, follow these steps:
    1. Click Start, point to All Programs, point to Microsoft SQL Server, and then click Enterprise Manager.
    2. In SQL Server Enterprise Manager, expand the server, expand Databases, expand Organization_Name_MSCRM, and then click Table.
    3. In the details pane, right-click DocumentIndex, point to Full-Text Index Table, and then click Remove Full-Text Indexing from a Table.
  2. Run the following script in SQL Query Analyzer against the Organization_Name_MSCRM database:
    exec sp_fulltext_database 'enable' 
    go 
    exec sp_fulltext_catalog 'ftcat_documentindex', 'create' 
    go 
    exec sp_fulltext_table 'documentindex', 'create', 'ftcat_documentindex', 'PK_documentindex' 
    go 
    exec sp_fulltext_column 'documentindex', 'Title', 'add' 
    go 
    exec sp_fulltext_column 'documentindex', 'KeyWords', 'add' 
    go 
    exec sp_fulltext_column 'documentindex', 'SearchText', 'add' 
    go 
    exec sp_fulltext_table 'documentindex', 'activate' 
    go 
    exec sp_fulltext_catalog 'ftcat_documentindex', 'start_full' 
    go 
    
    
  3. Enable full-text indexing, and then set up the catalog for indexing. To do this, follow these steps:
    1. Click Start, point to All Programs, point to Microsoft SQL Server, and then click Enterprise Manager.
    2. In SQL Server Enterprise Manager, expand the server, expand Databases, expand Organization_Name_MSCRM, and then click Table.
    3. Right-click the DocumentIndex table, point to Full-Text Index Table, and then click Define Full-Text Indexing on a Table.
    4. Click to select all the check boxes on the Select Table Columns page, and then leave the default settings on the remaining wizard pages.
    5. Under the Organization_Name_MSCRM database, click Full-Text Catalogs.
    6. In the details pane, right-click ftcat_documentindex, and then click Rebuild Catalog.
    7. Right-click ftcat_documentindex, and then click Start Full Population.
    8. Right-click ftcat_documentindex, and then click Start Incremental Population.
    9. In SQL Server Enterprise Manager, expand Support Services, right-click Full-Text Search, and then click Start.

↑ Back to the top


Keywords: KB927226, kbprb, kbmbsmigrate, kbmbsupgrade, kbtshoot, kberrmsg, kbmsicuu2

↑ Back to the top

Article Info
Article ID : 927226
Revision : 5
Created on : 2/18/2011
Published on : 2/18/2011
Exists online : False
Views : 550