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When a user logs off a Windows Server 2003 Service Pack 1 or Service Pack 2-based terminal server, the terminal server may stop responding for several seconds


View products that this article applies to.

Symptoms

When a user logs off a Microsoft Windows Server 2003 Service Pack 1 (SP1) or Service Pack 2 (SP2)-based terminal server, the terminal server may stop responding (hang) for several seconds.

Note If many users log off at the same time, this behavior may be exacerbated. In this scenario, the unresponsiveness may last several seconds or several minutes. Additionally, the behavior may become more noticeable to users who are still logged on.

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Cause

This problem occurs because of the way that Windows Server 2003 Service Pack 1 (SP1) or Service Pack 2 (SP2) cleans up user registry information. When a user logs off, there is a five-second delay before Windows Server 2003 SP1 or SP2 flushes the user registry hive. If the terminal server experiences heavy registry activity, the cached registry information on the terminal server may increase significantly. For example, this behavior may occur when a program scans the user profile during the logoff process. When the terminal server experiences heavy registry activity, it takes Windows longer to flush the data.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must be running Windows Server 2003 Service Pack 1 (SP1) or a later service pack to apply this hotfix. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, x86 versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntkrnlmp.exe5.2.3790.28682,460,16024-Jan-200712:16Not ApplicableSP1SP1QFE
Ntkrnlpa.exe5.2.3790.28682,271,74424-Jan-200711:25x86SP1SP1QFE
Ntkrpamp.exe5.2.3790.28682,312,19224-Jan-200711:25Not ApplicableSP1SP1QFE
Ntoskrnl.exe5.2.3790.28682,420,73624-Jan-200712:16x86SP1SP1QFE
Ntkrnlmp.exe5.2.3790.40102,469,37624-Jan-200719:41Not ApplicableSP2SP2QFE
Ntkrnlpa.exe5.2.3790.40102,281,47224-Jan-200718:36x86SP2SP2QFE
Ntkrpamp.exe5.2.3790.40102,321,40825-Jan-200711:56Not ApplicableSP2SP2QFE
Ntoskrnl.exe5.2.3790.40102,430,46424-Jan-200719:40x86SP2SP2QFE
Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntkrnlmp.exe5.2.3790.28684,628,99225-Jan-200715:06x64SP1SP1QFE
Ntoskrnl.exe5.2.3790.28684,483,58425-Jan-200715:06x64SP1SP1QFE
Ntkrnlmp.exe5.2.3790.40104,566,52825-Jan-200715:11x64SP2SP2QFE
Ntoskrnl.exe5.2.3790.40104,496,89625-Jan-200715:11x64SP2SP2QFE
Windows Server 2003, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntkrnlmp.exe5.2.3790.28686,521,34425-Jan-200707:34IA-64SP1SP1QFE
Ntkrnlmp.exe5.2.3790.40106,534,65625-Jan-200712:17IA-64SP2SP2QFE

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbbug, kbfix, kbhotfixserver, kbqfe, KB927182

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Article Info
Article ID : 927182
Revision : 3
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 258