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The first PrepareRecips function call incorrectly returns an S_OK error code instead of an MAPI_E_END_OF_SESSION error code in Exchange Server 2003


View products that this article applies to.

Symptoms

Consider the following scenario:
  • A MAPI program connects to a mailbox store that is running Microsoft Exchange Server 2003 with Service Pack 1.
  • The MAPI program uses the MAPI address book provider that is included in Exchange Server 2003.
  • Global catalog referral is enabled on the server that is running Exchange Server 2003.
  • The current global catalog server that the MAPI program points to becomes unavailable.
In this scenario, the first PrepareRecips function call incorrectly returns an S_OK error code instead of an MAPI_E_END_OF_SESSION error code.

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Cause

If the current global catalog server that MAPI uses is unavailable, the address book provider switches to another available global catalog server. Then, the IAddrBook::PrepareRecips() method returns the S_OK error code instead of the MAPI_E_END_OF_SESSION error code.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Because of file dependencies, this hotfix requires that you have Microsoft Exchange Server 2003 Service Pack 2 (SP2) installed.

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, the following services are automatically restarted when you apply this hotfix:
  • Microsoft Exchange Management
  • Microsoft Exchange Information Store
  • Microsoft Exchange System Attendant

Hotfix replacement information

This hotfix does not replace any other hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Emsabp32.dll6.5.7652.0172,54420-Nov-200617:40x86
Mapi32.dll6.5.7652.0636,92820-Nov-200617:28x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about a similar issue in Microsoft Exchange 2000 Server, click the following article number to view the article in the Microsoft Knowledge Base:
823719 Exchange 2000 MAPI address book provider cannot connect to a different global catalog server if the current global catalog server is unavailable

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Keywords: KB926924, kbbug, kbfix, kbqfe, kbHotfixServer, kbautohotfix, kbarchive, kbnosurvey

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Article Info
Article ID : 926924
Revision : 5
Created on : 1/15/2015
Published on : 1/15/2015
Exists online : False
Views : 378