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The filter criteria on a multivalued field are not displayed after a filter is applied in Access 2007


View products that this article applies to.

Symptoms

In Microsoft Office Access 2007, the filter criteria on a multivalued field are not displayed after a filter is applied. For example, when you click Filter in the Sort & Filter group on the Home tab the applied filter criteria are not displayed. Or, when you click the filter icon in the datasheet header, the applied filter criteria are not displayed. Instead, no filter criteria appear to have been set. This is true even though you may see the word Filtered on both the record Navigation Bar and the Status Bar.

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Cause

This problem occurs if the following conditions are true:
  • The data that is being filtered contains multiple values in a record of the column that is being filtered.
  • A filter has been applied to the data.

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Workaround

To work around this problem, use one of the following methods.

Method 1: View the applied filter criteria

To view the applied filter criteria, use one of the following procedures:
  • Rest the mouse pointer on the column heading in the datasheet. A tip will appear that shows the current filter criteria.
  • On the Home tab in the Sort & Filter group, click Advanced, and then click Advanced Filter/Sort.

Method 2: Change the applied filter criteria

To change the applied filter criteria, use one of the following procedures:
  • Click Filter in the Sort & Filter group on the Home tab, or click the filter icon in the datasheet header. Then, follow these steps:
    1. Click to clear the Select All check box.
    2. Click to select each filter criteria check box as needed.
    3. Click OK.
  • On the Home tab, click Advanced in the Sort & Filter group, and then click Advanced Filter/Sort. Make the needed changes to the criteria field, and then click Close.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

The criteria for multivalued fields that you see in the filter window may not accurately display the applied filter criteria. This problem may occur in tables and queries, or the problem may occur for the Filter property for forms, reports, and recordset objects. However, the existing filters are still applied correctly.

For more information about how to use an advanced filter, click Microsoft Office Access Help, or press F1. Type about filtering records in the Search box, and then click Search to view the topics that are returned.

For more information about multivalued fields, click Microsoft Office Access Help, or press F1. Type Guide to multivalued fields in the Search box, and then click Search to view the topics returned.

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Keywords: KB926701, kbexpertiseinter, kbprb, kbdatabase, kbfilter, kbtshoot

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Article Info
Article ID : 926701
Revision : 4
Created on : 10/15/2007
Published on : 10/15/2007
Exists online : False
Views : 264