Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The Microsoft Exchange Event service stops responding on an Exchange 2003 server


View products that this article applies to.

Symptoms

When you use the Microsoft Exchange Event service on a server that is running Microsoft Exchange Server 2003, the Microsoft Exchange Event service stops responding.

↑ Back to the top


Cause

This problem occurs because of a thread deadlock.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Microsoft Exchange Server 2003 Service Pack 2 (SP2) must be installed on the server before you apply this hotfix. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart your computer after you apply this hotfix. However, the Microsoft Exchange Event service is automatically stopped and then restarted when you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Events.exe6.5.7652.1294,72002-Feb-200704:06x86

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

When this problem occurs, the following call stack is generated.

Stack output
Deadlocked threads:

ChildEBP RetAddr  
00aae604 7c822124 ntdll!KiFastSystemCallRet
00aae608 7c83970f ntdll!NtWaitForSingleObject+0xc
00aae644 7c839620 ntdll!RtlpWaitOnCriticalSection+0x19c
00aae664 61e4058c ntdll!RtlEnterCriticalSection+0xa8
00aae6d8 61e40e1a mapi32!HrCommonOpenStore+0x56               
00aae758 0b3b12c2 mapi32!SESSOBJ_OpenMsgStore+0x56
WARNING: Stack unwind information not available. Following frames may be wrong.
00aae7a8 0b3b75a0 3rd Party Agent DLL
00aafa60 0b3b74b3 3rd Party Agent DLL
00aafa74 0b3b10e0 3rd Party Agent DLL
00aafaa0 00408a9a 3rd Party Agent DLL
00aafbe8 00409ca6 events!LaunchAgent+0x126
00aafc80 6171eff6 events!CMsgSink::SaveChanges+0xd5
00aafca0 617106a9 emsmdb32!IXMSGFXRCV::EcRcv+0x3f2
00aafcb4 6171181e emsmdb32!FXRCVCTX::EcRcv+0x11
00aafcc8 6171fbc2 emsmdb32!FXRCVMGR::EcDoClient+0x39
00aafcf8 6171fc8f emsmdb32!IXCHGSYNC::EcSynchronize+0xf2
00aafd18 00402638 emsmdb32!IXMSGSYNC::Synchronize+0x22        
00aafd74 00402d7c events!EventHandlerSync+0xc9


ChildEBP RetAddr  
0095fb18 7c822124 ntdll!KiFastSystemCallRet
0095fb1c 7c83970f ntdll!NtWaitForSingleObject+0xc
0095fb58 7c839620 ntdll!RtlpWaitOnCriticalSection+0x19c
0095fb78 61726c18 ntdll!RtlEnterCriticalSection+0xa8
0095fc24 61e41161 emsmdb32!RMSP_Logon+0x133                    
0095fc84 61e40e79 mapi32!HrIntDoOneClientLogon+0x91
0095fca0 61e40904 mapi32!HrIntClientStoreLogon+0x50
0095fd14 61e40e1a mapi32!HrCommonOpenStore+0x3ce                
0095fd94 00407510 mapi32!SESSOBJ_OpenMsgStore+0x56
0095fdf0 00407941 events!CBindingManager::NewBoundFolder+0xb5
0095fef8 0040e79b events!CBindingManager::Notify+0x265
0095ff68 00409275 events!CMaintainence::hrWait+0x1a3
0095ffa4 77f79348 events!ServiceMain+0x2be
0095ffb8 77e66063 advapi32!ScSvcctrlThreadA+0x21
0095ffec 00000000 kernel32!BaseThreadStart+0x34

↑ Back to the top


Keywords: KB926662, kbqfe, kbhotfixserver, kbexpertiseinter, kbautohotfix

↑ Back to the top

Article Info
Article ID : 926662
Revision : 5
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 232