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The Windows Communication Foundation WMI provider is not registered when you install the .NET Framework 3.0 on a Windows Server 2003-based computer


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Symptoms

When you install the Microsoft .NET Framework 3.0 on a Microsoft Windows Server 2003-based computer, you experience the following problems:
  • The .NET Framework 3.0 is installed successfully. However, the Windows Communication Foundation (WCF) Windows Management Instrumentation (WMI) provider is not registered.
  • An event is logged in the Application log about the failure to register the WCF WMI provider or about the failure to run the Mofcomp.exe file.
  • The %windir%\Temp\dd_wcf_retCA* setup trace log file contains entries about the failure to register the WCF WMI provider.

    Note %windir% represents the path of the Windows system folder. Typically, C:\Windows is the path of the Windows system folder.
  • You receive one of the following exception errors in the Application log or in the setup trace log file:
    Error message 1
    ServiceModelReg [11:09:59:046]: System.ApplicationException: Unexpected result 3 executing E:\WINDOWS\system32\wbem\mofcomp.exe with "E:\WINDOWS\Microsoft.NET\Framework\v3.0\Windows Communication Foundation\ServiceModel.mof"
    Error message 2
    ServiceModelReg [07:19:33:843]: System.TypeInitializationException: The type initializer for 'System.Management.ManagementPath' threw an exception. ---> System.Runtime.InteropServices.COMException (0x80040154): Retrieving the COM class factory for component with CLSID {CF4CC405-E2C5-4DDD-B3CE-5E7582D8C9FA} failed due to the following error: 80040154.
    Error message 3
    ServiceModelReg [07:19:32:750]: System.IO.FileNotFoundException: Could not load file or assembly 'C:\WINDOWS\system32\wbem\mofcomp.exe' or one of its dependencies. The system cannot find the file specified. File name: 'C:\WINDOWS\system32\wbem\mofcomp.exe

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Cause

This problem may occur if the WMI service is corrupted. Therefore, the WCF installer cannot use the Mofcomp.exe file to register the WCF .mof file.

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Resolution

To resolve this problem, follow these steps:
  1. Run the WMI Diagnosis utility to diagnose and to repair problems with the WMI service.

    To download the WMI Diagnosis utility, visit the following Microsoft Web site:For more information about the WMI Diagnosis utility, visit the following Microsoft Web site:
  2. Use Add or Remove Programs to repair the .NET Framework 3.0 installation, or remove and then reinstall the .NET Framework 3.0.

    To repair the .NET Framework 3.0 installation, follow these steps:
    1. Click Start, click Run, type appwiz.cpl, and then click OK.
    2. In the Currently installed programs list, click Microsoft .NET Framework 3.0, and then click Change/Remove.
    3. Click Repair, and then click Next.
    4. Follow the instructions to repair the .NET Framework 3.0 installation.
    To remove and then reinstall the .NET Framework 3.0, follow these steps:
    1. Click Start, click Run, type appwiz.cpl, and then click OK.
    2. In the Currently installed programs list, click Microsoft .NET Framework 3.0, and then click Change/Remove.
    3. Click Uninstall, and then click Next.
    4. Follow the instructions to remove the .NET Framework 3.0 program.
    5. Reinstall the .NET Framework 3.0.

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Keywords: KB926640, kbtshoot, kbexpertiseadvanced, kbmgmtservices, kbwinservperf, kbprb

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Article Info
Article ID : 926640
Revision : 2
Created on : 11/30/2006
Published on : 11/30/2006
Exists online : False
Views : 190