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Error message when a client tries to access resources on a Web site that uses ADFS: "Access is Denied"


View products that this article applies to.

Symptoms

After a client successfully authenticates on a Web site that uses Active Directory Federation Services (ADFS), the client receives the following error message when the client tries to access a resource on the Web site:
Access is Denied
When this problem occurs, the following event is logged in the Application log on the server that hosts the Web site:

Event Type: Warning
Event Source: ADFS ISAPI Extension
Event Category: None
Event ID: 107
User: N/A
Description: The ADFS Web Agent Internet Server Application Programming Interface (ISAPI) Extension was unable to obtain a Windows NT token from the authentication service.

This problem occurs if the following conditions are true:
The server is running Microsoft Windows Server 2003 R2.
The server is running ADFS.
The server acts as a resource federation server that supports single sign-on authentication for an ADFS-enabled Web site.

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Cause

This problem occurs because the incoming group claims of the account partner are unexpectedly removed. This situation occurs if the following conditions are true:
The resource group for an organization group claim has been modified.
The incoming group claims are mapped to this organization group claim.

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Resolution

Hotfix information

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site: Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 R2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Federation.adminconsole.dll5.2.3790.28132,945,02416-Oct-200612:43x86
Windows Server 2003 R2, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Federation.adminconsole.dll5.2.3790.28132,945,02415-Oct-200622:07x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: kbexpertiseinter, kbbug, kbfix, kbhotfixserver, kbqfe, kbpubtypekc, kbwinserv2003postsp2fix, KB926408

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Article Info
Article ID : 926408
Revision : 3
Created on : 8/17/2007
Published on : 8/17/2007
Exists online : False
Views : 277