Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: Error message in Visual Studio when you try to open a BizTalk Server 2006 map: "Failed to load the source schema"


View products that this article applies to.

Symptoms

In Microsoft Visual Studio, you receive an error message that resembles the following when you try to open a Microsoft BizTalk Server 2006 map:
Failed to load the source schema (schema_name). Would you like to select another schema using BizTalk Type Picker?�
Note In this error message, the schema_name placeholder represents the name of a schema in a referenced project.

When you click Yes, you receive an error message that resembles the following:
Failed to load the source schema
When you exit visual studio, you receive an error message that resembles the following:
Microsoft Visual Studio has encountered a problem and needs to close

↑ Back to the top


Cause

This problem occurs when the schema hierarchy is not a ComObject type. The BizTalk Schema Picker processes all hierarchies as ComObject types.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
Microsoft.biztalk.artifactbrowser.dll3.5.1625.0199,48806-Oct-200620:29
Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

This problem is known to occur when the unit testing tools are installed on the computer. The unit testing tools are included in the following versions of Microsoft Visual Studio:
  • Microsoft Visual Studio 2005 Team Suite
  • Microsoft Visual Studio 2005 Team Edition for Software Developers
  • Microsoft Visual Studio 2005 Team Edition for Software Testers

↑ Back to the top


References

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbautohotfix, kbbtsmapper, kbbts, kbbug, kbfix, kbpubtypekc, kbhotfixserver, kbqfe, kbbiztalk2006presp1fix, KB926344

↑ Back to the top

Article Info
Article ID : 926344
Revision : 5
Created on : 11/15/2007
Published on : 11/15/2007
Exists online : False
Views : 448