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When you use Windows Server 2003 or Windows XP to modify a Windows Vista registry hive, Windows Vista registry key flags are removed


View products that this article applies to.

Symptoms

When you use Microsoft Windows Server 2003 or Microsoft Windows XP to modify a Windows Vista registry hive, Windows Vista registry key flags are removed. If you delete a registry subkey from the Windows Vista registry hive, the registry flags are cleared from the parent key of that deleted registry subkey. For example, assume that you delete the "B" registry subkey from the following sample registry path:
HKEY_LOCAL_MACHINE\SOFTWARE\A\B
In this case, Windows Server 2003 or Windows XP removes the registry flags from the "A" registry subkey.

Note You may experience this problem if you use the Windows Automated Installation Kit (WAIK) or the Windows OEM Preinstallation Kit (OPK) to modify .wim image files in Windows Server 2003 or in Windows XP. For example, you may experience this problem if you use the Imagex.exe program to mount a Windows Vista image and then use Registry Editor to load and to modify a Windows Vista registry hive. Also, you may experience this problem if you use the Pkgmrg.exe program to configure Optional Windows Features in Windows Vista or to install updates.

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Cause

This problem occurs because Windows Server 2003 and Windows XP do not recognize new registry flags that are introduced in Windows Vista. Therefore, when you use Windows Server 2003 or Windows XP to modify the Windows Vista registry, these attribute flags may be cleared.

The Windows Vista registry includes the following attribute flags:
  • REG_KEY_DONT_VIRTUALIZE
  • REG_KEY_DONT_SILENT_FAIL
  • REG_KEY_RECURSE_FLAG
These flags are associated with each registry key. The flags are used to define virtualization behavior to support program compatibility with Windows Vista User Account Control (UAC). For more information about registry virtualization for UAC, visit the following Microsoft Web sites:

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Resolution

Windows Server 2003 service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Windows Server 2003 hotfix information

Prerequisites

Because of file dependencies, you must be running Windows Server 2003 Service Pack 1 (SP1) to apply this hotfix. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntkrnlmp.exe5.2.3790.28032,459,64829-Sep-200611:22Not ApplicableSP1SP1QFE
Ntkrnlpa.exe5.2.3790.28032,271,74429-Sep-200610:49x86SP1SP1QFE
Ntkrpamp.exe5.2.3790.28032,311,68029-Sep-200610:50Not ApplicableSP1SP1QFE
Ntoskrnl.exe5.2.3790.28032,420,22429-Sep-200611:22x86SP1SP1QFE
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntkrnlmp.exe5.2.3790.28034,627,96829-Sep-200615:21x64SP1SP1QFE
Ntoskrnl.exe5.2.3790.28034,483,07229-Sep-200615:21x64SP1SP1QFE
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Ntkrnlmp.exe5.2.3790.28036,520,32029-Sep-200615:15IA-64

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Windows XP hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Because of file dependencies, you must be running Windows XP Service Pack 2 (SP2) to apply this hotfix. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

322389 How to obtain the latest Windows XP service pack

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntkrnlmp.exe5.1.2600.30042,137,60029-Sep-200610:39x86SP2SP2QFE
Ntkrnlpa.exe5.1.2600.30042,058,88029-Sep-200609:47x86SP2SP2QFE
Ntkrpamp.exe5.1.2600.30042,017,28029-Sep-200609:47x86SP2SP2QFE
Ntoskrnl.exe5.1.2600.30042,181,76029-Sep-200610:41x86SP2SP2QFE
Windows XP, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntkrnlmp.exe5.2.3790.28034,627,96829-Sep-200615:21x64SP1SP1QFE
Ntoskrnl.exe5.2.3790.28034,483,07229-Sep-200615:21x64SP1SP1QFE

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows Server 2003 Service Pack 2.

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More Information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kb, kbautohotfix, kbwinserv2003sp2fix, kbwinxppresp3fix, kbentirenet, kbbug, kbfix, kbqfe, kbpubtypekc, kbhotfixserver, kbwinserv2003presp2fix

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Article Info
Article ID : 926044
Revision : 3
Created on : 4/23/2018
Published on : 4/23/2018
Exists online : False
Views : 321