Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Error message when you re-install ISA Server 2004 and CSS on a computer that is a member of an ISA Server array


View products that this article applies to.

Symptoms

You try to re-install Microsoft Internet Security and Acceleration (ISA) Server 2004 Enterprise Edition and Configuration Storage Server (CSS) in replication mode on a computer that is a member of an ISA Server array. When you do this, you may receive an error message that resembles the following:
Setup failed to install ADAM in replica mode (Active Directory could not create the NTDS Settings object for this directory server CN=NTDS Settings,CN=<ServerName>$ISASTGCTRL,CN=Servers,CN=<Default-First-Site-Name>,CN=Sites,CN=Configuration,�.) on the remote directory server <ServerName>.domainname.com:2171. Ensure the provided network credentials have sufficient permissions.
Error code: 0x80072071
An attempt was made to add an object to the directory with a name that is already in use.
Additionally, you may find an entry that resembles the following in the installation log:
<Time> ISA setup CA ERROR : Adam_Install(2) failed, ec=0x80074e46
Time ISA setup CA INFO : Adam_Install(3) : reported ERROR is 'Active Directory could not create the NTDS Settings object for this directory server CN=NTDS Settings,CN=Node2$ISASTGCTRL,CN=Servers,CN=Default-First-Site-Name,CN=Sites,CN=Configuration,.... on the remote directory server Node1.domainname.com:2171. Ensure the provided network credentials have sufficient permissions. Error code: 0x80072071 An attempt was made to add an object to the directory with a name that is already in use.'
Time ISA setup CA ERROR : ExecuteAdamSetup: ADAM setup failed failed, hr=0x80074e46
Time ISA setup CA ERROR : ExecuteAdamSetup(NOT FIRST_ADAM_IN_ENTERPRISE) failed
Time ISA setup CA ERROR : DisplayPopup: Setup failed to install ADAM in replica mode. (Active Directory could not create the NTDS Settings object for this directory server CN=NTDS Settings,CN=<Servername>$ISASTGCTRL,CN=Servers,CN=Default-First-Site-Name,CN=Sites,CN=Configuration,�. on the remote directory server ServerName.domainname.com:2171. Ensure the provided network credentials have sufficient permissions.
Error code: 0x80072071
An attempt was made to add an object to the directory with a name that is already in use.)

↑ Back to the top


Cause

This issue occurs if inconsistent data that relates to an earlier installation of CSS and of ISA Server exists in the Active Directory Application Mode (ADAM) directory data store.

↑ Back to the top


Resolution

To resolve this issue, remove the data that relates to the earlier installation. To do this, follow these steps:
  1. Use an account that has administrative credentials to log on to the computer where you are trying to re-install CSS and ISA Server.
  2. Click Start, point to All Programs, point to ADAM, and then click ADAM ADSI Edit.
  3. In the console tree, right-click ADAM ADSI Edit, and then click Connect to.
  4. In the Connection Settings dialog box, type a display name for the connection in the Connection name box. The connection is listed in the console tree.
  5. In the Server name list, click localhost.
  6. In the Port box, type 2171.
  7. Click Select a well known Naming Context, and then click Configuration in the Select a well known Naming Context list.
  8. Under Connect using these credentials, click The account of the currently logged on user, and then click OK.
  9. Remove the node that points to the earlier installation of CSS. To do this, follow these steps:
    1. In the right pane of the ADAM ADSI Edit MMC snap-in, expand CN=Configuration, expand CN=Sites, and then expand CN=Default_first_Site_Name.
    2. Expand CN=Servers, right-click Server_Name_Old, and then click Delete.

      Note Server_Name_Old is the name of the computer where CSS was previously installed.

↑ Back to the top


Keywords: KB925883, kberrmsg, kbtshoot, kbprb

↑ Back to the top

Article Info
Article ID : 925883
Revision : 5
Created on : 12/4/2007
Published on : 12/4/2007
Exists online : False
Views : 358