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Exchange 2003 is unable to convert .ics files to Outlook meeting items for multiple-event iCal files


View products that this article applies to.

Symptoms

When an external message includes attachments that are .ics files, Microsoft Exchange Server 2003 converts all the .ics files to Microsoft Office Outlook items. If the .ics files are single-event iCal files, Exchange 2003 correctly converts the .ics files to Outlook meeting items that you can open. However, if the .ics files are multiple-event iCal files, Exchange 2003 is unable to convert the files. Therefore, all the .ics files are not converted to Outlook meeting items.

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Cause

This problem occurs because Exchange 2003 unexpectedly converts the .ics files.

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Resolution

To resolve this issue, enable this hotfix after you apply it. To do this, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Click the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft
  3. On the Edit menu, point to New, click Key, type EXCDO, and then press ENTER.
  4. Click the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\EXCDO
  5. On the Edit menu, point to New, click Key, type Parameters, and then press ENTER.
  6. Click the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\EXCDO\Parameters
  7. On the Edit menu, point to New, and then click DWORD Value.
  8. In the details pane, type DoNotConvertIcalAttachment, and then press ENTER.
  9. Right-click the DoNotConvertIcalAttachment registry entry, and then click Modify.
  10. In the Edit DWORD Value dialog box, click Decimal under Base.
  11. In the Value data box, type 1, and then click OK.
  12. Exit Registry Editor.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Microsoft Exchange Server 2003 Service Pack 2 (SP2) must be installed on the server before you apply this hotfix. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart the computer after you apply this hotfix.. However, the following services are automatically restarted when you apply this hotfix:
  • The Microsoft Exchange Information Store service
  • The Internet Information Services (IIS) Admin Service and all dependent services

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTime
Excdo.dll6.5.7653.73,634,68829-Jun-200703:00

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: KB925873, kbqfe, kbhotfixserver, kbexpertiseinter, kbautohotfix

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Article Info
Article ID : 925873
Revision : 5
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 250