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If you exit a program when the program is playing an audio file in Windows Server 2003, the program stops responding


View products that this article applies to.

Symptoms

If you exit a program when the program is playing an audio file in Microsoft Windows Server 2003, the program stops responding (hangs).

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Cause

This problem occurs because of a race condition that is triggered by the Msacm32.dll file.

Note A race condition occurs when the system tries to perform two or more operations at the same time. In this situation, the operations must be performed in the correct sequence to be completed successfully.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must install Windows Server 2003 Service Pack 1 (SP1) before you install the hotfix.

Note x64-based versions of Windows Server 2003 do not require Windows Server 2003 SP1.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You do not have to restart the computer after you apply the hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.Microsoft Windows Server 2003, x-64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Msacm32.dll5.2.3790.2799114,68825-Sep-200601:30x64SP1SP1QFE
Wmsacm32.dll5.2.3790.279971,16825-Sep-200601:30x86SP1WOW
Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Msacm32.dll5.2.3790.2799282,62425-Sep-200601:29IA-64SP1SP1QFE
Wmsacm32.dll5.2.3790.279971,16825-Sep-200601:30x86SP1WOW
Microsoft Windows Server 2003, 32-bit versions
File nameFile versionFile sizeDateTimePlatform
Msacm32.dll5.2.3790.279971,16825-Sep-200613:20x86

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Workaround

To work around this problem, disable all audio functionality in the affected program. For more information about how to do this, see the program's Help files, or contact the program's manufacturer.

For information about your hardware manufacturer, visit the following Web site: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Technical support for x64-based versions of Microsoft Windows

Your hardware manufacturer provides technical support and assistance for x64-based versions of Windows. Your hardware manufacturer provides support because an x64-based version of Windows was included with your hardware. Your hardware manufacturer might have customized the installation of Windows with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your x64-based version of Windows. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Microsoft Windows Server 2003, visit the following Microsoft Web site:

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Keywords: kbwinserv2003sp2fix, kbsound, kbwinserv2003presp2fix, kbfix, kbbug, kbHotfixServer, kbqfe, kbautohotfix, KB925752

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Article Info
Article ID : 925752
Revision : 3
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 264