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The LegacyExchangeDN attribute for two user accounts may be the same in Exchange Server 2003 SP2


View products that this article applies to.

Symptoms

Consider the following scenario. In Microsoft Exchange Server 2003 Service Pack 2 (SP2), you create two or more user accounts. The aliases for these user accounts contain a number sign (#). For example, you create the userA# account and the userB# account. Then, you create the Exchange mailboxes for these users. In this scenario, the LegacyExchangeDN attribute for each of these users may be the same. This behavior occurs if the following conditions are true:
  • The Recipient Update service is running on an Exchange Server 2003 SP2-based computer in a multiprocessor environment.
  • You create two or more Exchange mailboxes at the same time. For example, you select a group of users in Active Directory Users and Computers. You right-click Exchange Tasks and then click Create Mailbox.
Note Exchange Server 2003 disallows two or more users to have the same LegacyExchangeDN attribute. Therefore, e-mail messages that are sent to these mailboxes will not be delivered.

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Cause

This problem occurs because the CN attribute of the user account contains invalid LegacyDN characters. Therefore, Exchange Server 2003 appends a random number to the LegacyExchangeDN attribute to identify the user account. In a multiprocessor environment, the same random number may be used for different users. Therefore, the LegacyExchangeDN attribute for these user accounts may be the same.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Because of file dependencies, this hotfix requires Exchange Server 2003 SP2.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993 How to obtain the latest service packs for Exchange Server 2003
Also, the Recipient Update service must be running when you apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, you must restart the following services after you apply this hotfix:
  • The Microsoft Exchange Information Store service
  • The Microsoft Exchange MTA Stacks service
  • The Microsoft Exchange System Attendant service
  • The Microsoft Exchange Management service
  • The Microsoft Search service
  • The Simple Mail Transfer Protocol (SMTP) service
  • The Microsoft Exchange Routing Engine service
  • The Network News Transfer Protocol (NNTP) service
  • The HTTP SSL service
  • The IIS Admin service

Hotfix replacement information

This hotfix does not replace any other software updates.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Cdoexm.dll6.5.7651.532,867,20003-Oct-200617:36x86
Exadmin.dll6.5.7651.5321,939,71203-Oct-200602:33x86
Exmgmt.exe6.5.7651.533,218,43203-Oct-200617:37x86
Exosal.dll6.5.7651.5370,14403-Oct-200617:35x86
Exsetdata.dll6.5.7651.533,714,04803-Oct-200616:50x86
Mad.exe6.5.7651.538,925,69603-Oct-200617:37x86
Maildsmx.dll6.5.7651.5314,647,29603-Oct-200617:34x86
Mdbmsg.dll6.5.7651.533,375,10403-Oct-200616:50x86
Store.exe6.5.7651.535,257,21603-Oct-200617:38x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
817903 New naming schema for Exchange Server software update packages

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Keywords: kbnosurvey, kbautohotfix, kbexpertiseinter, kbHotfixServer, kbqfe, kbfix, kbbug, kbarchive, KB925397

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Article Info
Article ID : 925397
Revision : 4
Created on : 1/15/2015
Published on : 1/15/2015
Exists online : False
Views : 434