Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Error message when you try to change the permissions on a folder on a Windows Server 2003 R2-based server: "The permissions on <Folder_name> are incorrectly ordered, which may cause some entries to be ineffective"


View products that this article applies to.

Symptoms

On a Microsoft Windows Server 2003 R2-based server, you receive the following error message when you try to change the permissions on a folder:
The permissions on <Folder_name> are incorrectly ordered, which may cause some entries to be ineffective. Press OK to continue and sort the permissions correctly, or Cancel to reset the permissions.
This problem occurs if the following conditions are true:
  • The folder was created by Distributed File System Replication (DFSR) during the replication process.
  • The current server is not designated as a master in the DFS replication group.
  • NTFS permission inheritance is disabled in the root folder.

↑ Back to the top


Cause

This problem occurs because DFSR incorrectly stores the access control entry (ACE) order.

↑ Back to the top


Resolution

After you apply this hotfix, the new folders that are created by DFSR will have the correct access control entry order. You can then manually delete the problematic folders that were created before you applied this hotfix. DFSR will re-create these folders during the replication process.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2003 R2.

Restart requirement

To avoid restarting the computer, you must stop the DFS Replication service before you apply this hotfix. Then, start the DFS Replication service after you apply the hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 R2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Dfsr.exe5.2.3790.28041,696,76803-Oct-200612:45x86SP1SP1QFE
Windows Server 2003 R2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Dfsr.exe5.2.3790.28043,580,92803-Oct-200600:40x64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kberrmsg, kbwinserv2003presp2fix, kbexpertiseinter, kbbug, kbfix, kbhotfixserver, kbqfe, kbpubtypekc, kbautohotfix, KB925332

↑ Back to the top

Article Info
Article ID : 925332
Revision : 6
Created on : 8/13/2007
Published on : 8/13/2007
Exists online : False
Views : 440