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An Access program stops responding when it uses the Jet Database Engine and runs a large SQL query that contains double-byte character set data in Windows Server 2003 and in Windows XP


View products that this article applies to.

Symptoms

Consider the following scenario:
  • On a Microsoft Windows Server 2003-based computer or on a Microsoft Windows XP-based computer, you run a large SQL query that contains double-byte character set (DBCS) data.
  • This DBCS data is contained in a Microsoft Access-based program that uses the Microsoft Jet Database Engine to process the SQL query.
  • You use the SQL query to retrieve data that is stored in the underlying base tables in Unicode data format.
In this scenario, when you run the SQL query, the Access-based program stops responding.

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Cause

This problem occurs because the Jet Database Engine incorrectly uses the WideCharToMultiByte function to calculate the length of the SQL query.

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Resolution

Windows Server 2003 service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Windows Server 2003 hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Dao360.dll3.60.9427.0551,71210-Oct-200607:13x86NoneRTMQFE
Msexcl40.dll4.0.9025.0326,36021-Jun-200500:21x86NoneRTMQFE
Msjet40.dll4.0.9427.01,510,17610-Oct-200607:13x86NoneRTMQFE
Msjtes40.dll4.0.9424.0248,60809-May-200622:19x86NoneRTMQFE
Mspbde40.dll4.0.9025.0355,03221-Jun-200500:21x86NoneRTMQFE
Msrepl40.dll4.0.9025.0552,99113-Oct-200601:32x86NoneRTMQFE
Mswdat10.dll4.0.9422.0838,43209-May-200622:19x86NoneRTMQFE
Mswstr10.dll4.0.9422.0621,34409-May-200622:19x86NoneRTMQFE
Msxbde40.dll4.0.9025.0355,03221-Jun-200500:21x86NoneRTMQFE
Dao360.dll3.60.9427.0551,71213-Oct-200608:29x86SP1SP1QFE
Msjet40.dll4.0.9427.01,510,17613-Oct-200608:29x86SP1SP1QFE
Msjtes40.dll4.0.9424.0248,53610-May-200623:00x86SP1SP1QFE
Mswdat10.dll4.0.9422.0838,36013-Jan-200623:16x86SP1SP1QFE
Mswstr10.dll4.0.9422.0621,27213-Jan-200623:16x86SP1SP1QFE
Windows Server 2003, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Wdao360.dll3.60.9427.0551,71213-Oct-200601:32x86NoneWOW
Wmsexcl40.dll4.0.9025.0326,36013-Oct-200601:32x86NoneWOW
Wmsjet40.dll4.0.9427.01,510,17613-Oct-200601:32x86NoneWOW
Wmsjtes40.dll4.0.9424.0248,60813-Oct-200601:32x86NoneWOW
Wmspbde40.dll4.0.9025.0355,03213-Oct-200601:32x86NoneWOW
Wmsrepl40.dll4.0.9025.0552,99113-Oct-200601:32x86NoneWOW
Wmswdat10.dll4.0.9422.0838,43213-Oct-200601:32x86NoneWOW
Wmswstr10.dll4.0.9422.0621,34413-Oct-200601:32x86NoneWOW
Wmsxbde40.dll4.0.9025.0355,03213-Oct-200601:32x86NoneWOW
Wdao360.dll3.60.9427.0551,71213-Oct-200601:39x86SP1WOW
Wmsjet40.dll4.0.9427.01,510,17613-Oct-200601:39x86SP1WOW
Wmsjtes40.dll4.0.9424.0248,53613-Oct-200601:39x86SP1WOW
Wmswdat10.dll4.0.9422.0838,36013-Oct-200601:39x86SP1WOW
Wmswstr10.dll4.0.9422.0621,27213-Oct-200601:39x86SP1WOW
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Wdao360.dll3.60.9427.0551,71213-Oct-200601:37x86SP1WOW
Wmsjet40.dll4.0.9427.01,510,17613-Oct-200601:37x86SP1WOW
Wmsjtes40.dll4.0.9424.0248,53613-Oct-200601:37x86SP1WOW
Wmswdat10.dll4.0.9422.0838,36013-Oct-200601:37x86SP1WOW
Wmswstr10.dll4.0.9422.0621,27213-Oct-200601:37x86SP1WOW

Windows XP hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Windows XP Service pack 2 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatformSP requirement
Dao360.dll3.60.9427.0551,71204-Jan-200708:30x86SP2
Msexcl40.dll4.0.9025.0326,36014-Dec-200613:38x86SP2
Msjet40.dll4.0.9427.01,510,17604-Jan-200708:30x86SP2
Msjtes40.dll4.0.9424.0248,53614-Dec-200613:38x86SP2
Mspbde40.dll4.0.9025.0355,03214-Dec-200613:38x86SP2
Msrepl40.dll4.0.9025.0552,99121-Jan-200717:19x86SP2
Mswdat10.dll4.0.9422.0838,36014-Dec-200613:38x86SP2
Mswstr10.dll4.0.9422.0621,27214-Dec-200613:38x86SP2
Msxbde40.dll4.0.9025.0355,03214-Dec-200613:38x86SP2

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Technical support for x64-based versions of Microsoft Windows

If your hardware came with a Microsoft Windows x64 edition already installed, your hardware manufacturer provides technical support and assistance for the Windows x64 edition. In this case, your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation by using unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with a Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware. If you purchased a Windows x64 edition such as a Microsoft Windows Server 2003 x64 edition separately, contact Microsoft for technical support.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Microsoft Windows Server 2003, visit the following Microsoft Web site:

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Keywords: kbautohotfix, kbwinserv2003sp2fix, kbexpertiseadvanced, kbbug, kbfix, kbHotfixServer, kbqfe, KB925051

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Article Info
Article ID : 925051
Revision : 4
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 264