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A non-delivery report message does not contain all the supplemental information in Exchange Server 2003


View products that this article applies to.

Symptoms

Consider the following scenario in Microsoft Exchange Server 2003:
  • The Locale ID property of your mailbox is set to a language that is not English.

    Note This condition occurs after you previously logged on to the mailbox from a Microsoft Outlook client or a computer whose language setting is other than English.
  • You send an e-mail message to an external address that does not exist in order to obtain a non-delivery report (NDR).
In this scenario, the NDR message may not contain all the supplemental information.

For example, if the Locale ID property of your mailbox is set to English, the NDR message resembles the following message:
Your message did not reach some or all of the intended recipients. Subject: subject Sent: Date and Time The following recipient(s) could not be reached: RecipientAddress on Date and Time The e-mail system was unable to deliver the message, but did not report a specific reason. Check the address and try again. If it still fails, contact your system administrator. <domain #5.0.0 SMTP; 573 username@domain.com: Sender address rejected: "Your e-mail could not be delivered successfully to domain.com>
However, if the Locale ID property of your mailbox is set to a language that is not English, the NDR message resembles the following message:
Your message did not reach some or all of the intended recipients. Subject: subject Sent: Date and Time The following recipient(s) could not be reached: RecipientAddress on Date and Time The e-mail system was unable to deliver the message, but did not report a specific reason. Check the address and try again. If it still fails, contact your system administrator.

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Cause

This problem occurs because the supplemental information is stored in the PR_SUPPLEMENTARY_INFO MAPI property of the NDR message. If the Locale ID property of the mailbox is set to a language that is not English, the supplementary information is discarded when the NDR is processed.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Because of file dependencies, this hotfix requires Microsoft Exchange Server 2003 Service Pack 2 (SP2) to be installed on the server.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993 � How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, the following services are automatically stopped and then restarted when you apply this hotfix:
  • Microsoft Search
  • Microsoft Exchange Information Store
  • World Wide Web Publishing Service
  • Simple Mail Transfer Protocol (SMTP)
  • Microsoft Exchange Routing Engine
  • Network News Transfer Protocol (NNTP)
  • HTTP SSL
  • IIS Admin Service

Hotfix replacement information

This hotfix does not replace any other hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Exosal.dll6.5.7652.570,14406-Dec-200606:57x86
Mdbmsg.dll6.5.7652.53,375,10406-Dec-200606:12x86
Store.exe6.5.7652.55,258,75206-Dec-200607:00x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
812806� Exchange user unexpectedly receives a standard NDR instead of a custom NDR

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Keywords: KB925004, kbhotfixserver, kbqfe, kbexchtransport, kbexpertisebeginner, kbautohotfix

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Article Info
Article ID : 925004
Revision : 6
Created on : 10/25/2007
Published on : 10/25/2007
Exists online : False
Views : 367