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The e-mail program stops responding when you send e-mail that has an attachment in Windows Server 2003


View products that this article applies to.

Symptoms

When you use Microsoft Collaboration Data Objects for Windows (CDOSYS) in Microsoft Windows Server 2003 to send an e-mail message that has an attachment, the e-mail program stops responding.

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Cause

This problem may occur if the HKEY_CLASSES_ROOT registry subtree contains a registry subkey that is longer than 133 characters.

CDOSYS uses the RegEnumKeyEx API to enumerate the HKEY_CLASSES_ROOT registry subtree to find all the different file name extensions. CDOSYS does this so that it can stamp the correct MIME type for the attachment. If CDOSYS encounters a registry subkey that is longer than 133 characters, CDOSYS may stop responding.

Program IDs (ProgIDs) for .NET assemblies sometimes use very long registry keys.

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Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Hotfix information

Prerequisites

To apply this hotfix, your computer must be running one of the following operating systems:
  • A 32-bit version of Windows Server 2003 with Service Pack 1 (SP1)
  • An Itanium-based version of Windows Server 2003 with SP1
  • An x64-based version of Windows

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Advapi32.dll5.2.3790.2859620,03210-Jan-200712:54x86SP1Not Applicable
Advapi32.dll5.2.3790.4003618,49610-Jan-200712:08x86SP2SP2QFE
Updspapi.dll6.3.4.1379,18427-Dec-200607:40x86SP1Not Applicable
Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Advapi32.dll5.2.3790.28601,051,13612-Jan-200712:07x64SP1Not Applicable
Advapi32.dll5.2.3790.40041,051,64812-Jan-200713:45x64SP2SP2QFE
Wadvapi32.dll5.2.3790.4004618,49612-Jan-200713:45x86SP2WOW
Updspapi.dll6.3.4.1462,12812-Jan-200713:46x64SP1Not Applicable
Wadvapi32.dll5.2.3790.2860620,03212-Jan-200712:07x86SP1WOW
Windows Server 2003, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Advapi32.dll5.2.3790.28591,480,70410-Jan-200714:03IA-64SP1Not Applicable
Advapi32.dll5.2.3790.40031,481,21610-Jan-200716:08IA-64SP2SP2QFE
Wadvapi32.dll5.2.3790.4003618,49610-Jan-200716:08x86SP2WOW
Updspapi.dll6.3.4.1655,15210-Jan-200718:38IA-64SP1Not Applicable
Wadvapi32.dll5.2.3790.2859620,03210-Jan-200714:03x86SP1WOW

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.

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More information

For more information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915� New file naming schema for Microsoft Windows software update packages
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates


Technical support for x64-based versions of Microsoft Windows

If your hardware came with a Microsoft Windows x64 edition already installed, your hardware manufacturer provides technical support and assistance for the Windows x64 edition. In this case, your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation by using unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with a Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware. If you purchased a Windows x64 edition such as a Microsoft Windows Server 2003 x64 edition separately, contact Microsoft for technical support.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Microsoft Windows Server 2003, visit the following Microsoft Web site:

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Keywords: kbwinserv2003sp2fix, kbfix, kbhotfixserver, kbqfe, kbprb, kbexpertiseinter, KB924940

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Article Info
Article ID : 924940
Revision : 8
Created on : 10/11/2007
Published on : 10/11/2007
Exists online : False
Views : 280