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Appointments appear off by one hour when you use Collaboration Data Objects to obtain calendar information from Exchange Server 2003


View products that this article applies to.

Symptoms

You have a device that uses Collaboration Data Objects (CDO) 1.21 to connect to Microsoft Exchange Server 2003. When you use this device to view appointments or recurring meetings in your calendar, you notice that the meeting times are incorrect by one hour at certain times of the year.

You experience this problem if the following conditions are true:
  • You use the Santiago (GMT -04:00) time zone.
  • You view the meeting times during daylight saving time.

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Cause

This problem occurs because CDO 1.21 does not contain the correct time zone information�for Santiago, Chile.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Because of file dependencies, you must have Exchange Server 2003 Service Pack 2 (SP2) installed to apply this hotfix.

For more information about how to obtain Exchange Server 2003 SP 2, click the following article number to view the article in the Microsoft Knowledge Base:
836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Cdo.dll6.5.7651.55718,33611-Oct-200622:56x86
Cdoex.dll6.5.7651.553,945,47212-Oct-200600:33x86
Davex.dll6.5.7651.551,131,00812-Oct-200600:29x86
Excdo.dll6.5.7651.553,631,10412-Oct-200600:33x86
Exoledb.dll6.5.7651.552,612,22412-Oct-200600:29x86

Hotfix installation information

After you install this hotfix, the following new time zone information is added for Santiago:
  • Time zone GMT -4:00, UTC +16:00
  • Daylight saving time transition This subtracts one hour from the current time. This starts on the second Saturday in October at 11:59:59 PM (23:59:59).
  • Standard time transition This adds one hour to the current time. This starts on the second Saturday in March at 11:59:59 PM (23:59:59)

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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References

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
817903 New naming schema for Exchange Server software update packages
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

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Keywords: KB924580, kbbug, kbfix, kbqfe, kbhotfixserver, kbautohotfix, kbarchive, kbnosurvey

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Article Info
Article ID : 924580
Revision : 5
Created on : 1/16/2015
Published on : 1/16/2015
Exists online : False
Views : 256