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Exchange Server 2003: Inbound Mailflow Stops With Event ID 327, Error Code -1040


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Source: Microsoft Support

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Symptoms

Inbound mailflow inexplicably stops. Restarting the MSExchange Information Store service allows mail to flow again.

The Application Event log shows at least one of the following events:
Event ID     : 327
Raw Event ID : 327
Record Nr.   : 1212140
Category     : Exchange Store Driver
Source       : MSExchangeTransport
Type         : Warning
Generated    : 6/24/2005 12:15:03 PM
Written      : 6/24/2005 12:15:03 PM
Machine      : SERVERNAME
Message      : The following call : EcLocallyDeliverMsg to the store failed. Error 
code : -1040 (Message-ID  <03775D4D054A1B4EA343B73B306F32F4BF33E3@domain.com>). MDB 
: d0406611-93ec-413d-a4ae-5d1fded21166. FID : . MID : . File : D:\Program 
Files\Exchsrvr\Mailroot\vsi 1\Queue\NTFS_c2376e3a01c5783c0000374b.EML.

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Cause

The cause is unknown, but information store corruption is suspect.

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Resolution

The following steps fixed the problem:
  1. Run isinteg -s ServerName -fix -test alltests

    Refer to the following Microsoft Technical article for isinteg usage instructions:
    301460 Exchange Command-Line Parameters for the Isinteg.exe Tool
  2. Allow Information store maintenance to perform on online defragmentation of the databases.
  3. Use the ESEUTIL utility perform an offline defragmentation of the server's databases.

    Refer to the following Microsoft Exchange Technical article for online and offline defragmentation instructions:
    328804 How to defragment Exchange databases

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Keywords: KB924206, kbrapidpub, kbtshoot, kbprb

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Article Info
Article ID : 924206
Revision : 3
Created on : 10/30/2007
Published on : 10/30/2007
Exists online : False
Views : 333